summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2020-03-08 21:35:56 +0100
committerKr1ss2020-03-08 21:35:56 +0100
commit783f67b0f8fb684c6c140517788e3399e29a4746 (patch)
tree99d7a65a6b7552870204e9fee33a7a1f38ca8faa
parent843ced09fa747c14cf8e62dee376b665215ac496 (diff)
downloadaur-783f67b0f8fb684c6c140517788e3399e29a4746.tar.gz
print info message only if no `.cargo/` is found
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d8a44eecbc68..c43ba00492dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,12 +20,13 @@ sha256sums=('ac1f26ac5ea10d43b300675189c49437dcae7a9fca7e51f615058ab0550d27e5')
prepare() {
# Assist chroot builds with a persistent cargo cache (hat tip @ccorn for this patch)
- msg2 "NOTE : If you're building in a (clean) chroot and want a persistant"
- plain " cargo cache folder specific for this package, you can create"
- plain " an empty '.cargo' directory next to the 'PKGBUILD'. This will"
- plain " be recognized and used as CARGO_HOME."
if [ -d "$startdir/.cargo" ]; then
export CARGO_HOME="${CARGO_HOME:-$startdir/.cargo}"
+ else
+ msg2 "NOTE : If you're building in a (clean) chroot and want a persistant
+ cargo cache folder specific for this package, you can create
+ an empty '.cargo' directory next to the 'PKGBUILD'. This will
+ be recognized and used as CARGO_HOME."
fi
}