summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2021-05-30 13:26:18 +0200
committerKr1ss2021-05-30 13:26:18 +0200
commitb20d8462cef4287d194f084af9ed331cd3d19739 (patch)
treec3a93bdf7508af3dd717c5e5fc33f8d9592c95b2
parentf84d171a91e1bf31ad43ad28fb444408f68d44b0 (diff)
downloadaur-b20d8462cef4287d194f084af9ed331cd3d19739.tar.gz
make sure to build with `stable` rust toolchain
Compiling `git2` with `nightly` currently fails, because of a regression bug, reported at: https://github.com/rust-lang/rust/issues/85574 Hat tip @K900 for notification via the AUR comment.
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f068f529089..2ed3ce1ef186 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,11 +35,15 @@ prepare() {
build() {
cd "$_name-$pkgver"
+ # git2 cannot be built with current nightly due to a regression; for ref.:
+ # https://github.com/rust-lang/rust/issues/85574
+ RUSTUP_TOOLCHAIN=stable \
cargo build --release --locked --target-dir ./target
}
check() {
cd "$_name-$pkgver"
+ RUSTUP_TOOLCHAIN=stable \
cargo test --release --locked --target-dir ./target
}