summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Dziedzic2012-04-07 12:00:16 +0000
committerEli Schwartz2015-06-09 01:22:14 -0500
commit2c5c95431823607b6dcc78070b5e06a43103c72a (patch)
tree4132aba3b533134b8ead670e56ab4750b46aec3c
parentb7013e9f65a7c803aed011589031169daee26016 (diff)
downloadaur-2c5c95431823607b6dcc78070b5e06a43103c72a.tar.gz
upgpkg: git-extras 1.5.1-1
Imported old history from aur-mirror: updated on Sat Apr 7 12:00:16 UTC 2012 filter-branch: add .SRCINFO
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 13 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39028e1918bc..6f1b0a7d92a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = git-extras
pkgdesc = GIT utilities -- repo summary, commit counting, repl, changelog population and more
- pkgver = 0.9.0
+ pkgver = 1.5.1
pkgrel = 1
url = http://github.com/visionmedia/git-extras
arch = any
- license = unknown
- makedepends = ronn
+ license = custom:MIT
depends = git
depends = bash
- source = git-extras-0.9.0.tar.gz::https://github.com/visionmedia/git-extras/tarball/0.9.0
- md5sums = b27235c1a3eaa18ba2f91e4a56a6c527
- sha256sums = 926ec2c50930e01f461a11eac13a16fd9fb91b852b67d7766810a5c5a986e00e
+ source = git-extras-1.5.1.tar.gz::https://github.com/visionmedia/git-extras/tarball/bbd32d8
+ md5sums = e7034197d57f31e9c5d6a081587ec9e1
+ sha256sums = 9061144559c4293f1b4a6eabe625e43f119cb17665382388634f210a304e822d
pkgname = git-extras
diff --git a/PKGBUILD b/PKGBUILD
index 25005994fe1d..5a44587a37f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,22 @@
# Maintainer: Thomas Jost <schnouki+aur@schnouki.net>
pkgname=git-extras
-pkgver=0.9.0
-_pkgtag=948308b
+pkgver=1.5.1
+_pkgtag=bbd32d8
pkgrel=1
pkgdesc="GIT utilities -- repo summary, commit counting, repl, changelog population and more"
arch=(any)
url="http://github.com/visionmedia/git-extras"
-license=('unknown')
+license=('custom:MIT')
depends=('git' 'bash')
-makedepends=('ronn')
-source=(git-extras-$pkgver.tar.gz::https://github.com/visionmedia/${pkgname}/tarball/${pkgver})
-md5sums=('b27235c1a3eaa18ba2f91e4a56a6c527')
-sha256sums=('926ec2c50930e01f461a11eac13a16fd9fb91b852b67d7766810a5c5a986e00e')
-
-build() {
- cd "$srcdir/visionmedia-$pkgname-$_pkgtag"
- sed -i 's! /etc! $(PREFIX)/etc!g' Makefile
-
- make docs
-
-}
+source=(git-extras-$pkgver.tar.gz::https://github.com/visionmedia/${pkgname}/tarball/${_pkgtag})
+md5sums=('e7034197d57f31e9c5d6a081587ec9e1')
+sha256sums=('9061144559c4293f1b4a6eabe625e43f119cb17665382388634f210a304e822d')
package() {
cd "$srcdir/visionmedia-$pkgname-$_pkgtag"
- make PREFIX="$pkgdir/usr" install
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et: