summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2020-06-08 14:46:46 -0400
committerEli Schwartz2020-06-08 14:46:46 -0400
commitaedd17c161a9f1eea220c9f01072251d49294629 (patch)
tree8737eef82ff7589168ebfded84643b912910aafe
parentf0504acd69936c0eec9298921f664b4da088a100 (diff)
downloadaur-aedd17c161a9f1eea220c9f01072251d49294629.tar.gz
upgpkg: git-extras 5.1.0-2
remove conflict with git-bug and possibly others; it's removed in upstream git already
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a06172670913..a2a7fa8aa83e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = git-extras
pkgdesc = GIT utilities -- repo summary, commit counting, repl, changelog population and more
pkgver = 5.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/tj/git-extras
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 589a8df9165f..a7b079f68166 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=git-extras
pkgver=5.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="GIT utilities -- repo summary, commit counting, repl, changelog population and more"
arch=('any')
url="https://github.com/tj/${pkgname}"
@@ -15,6 +15,16 @@ source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
sha256sums=('432f73f178345b69d98fb48ccdc04839bafb605f2f8cc3e5bb8f87d497ef3e7d')
b2sums=('279f0476c2ec6f30531d77d5c348bc6c0a823a622f7ec96ae65b1b2861a7c3ab1bf66eb246d031d0cfb4e1cc5fd3c2bfbf1418bc619dc3b81c6f0d7ffdcccd0a')
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # remove conflicting namespace with well-known projects
+ # https://github.com/tj/git-extras/issues/842
+ for i in bug chore refactor; do
+ rm -v bin/git-$i man/git-$i.*
+ done
+}
+
package() {
cd "${srcdir}/${pkgname}-${pkgver}"