summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Dziedzic2012-02-04 05:45:09 +0000
committerEli Schwartz2015-06-09 01:22:14 -0500
commitb7013e9f65a7c803aed011589031169daee26016 (patch)
treea792e578cb6f9fdd41f93a26dc272f9df509e6fc
downloadaur-b7013e9f65a7c803aed011589031169daee26016.tar.gz
Initial commit: git-extras 0.9.0-1
Imported old history from aur-mirror: updated on Sat Feb 4 05:45:09 UTC 2012 filter-branch: add .SRCINFO
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39028e1918bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = git-extras
+ pkgdesc = GIT utilities -- repo summary, commit counting, repl, changelog population and more
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = http://github.com/visionmedia/git-extras
+ arch = any
+ license = unknown
+ makedepends = ronn
+ depends = git
+ depends = bash
+ source = git-extras-0.9.0.tar.gz::https://github.com/visionmedia/git-extras/tarball/0.9.0
+ md5sums = b27235c1a3eaa18ba2f91e4a56a6c527
+ sha256sums = 926ec2c50930e01f461a11eac13a16fd9fb91b852b67d7766810a5c5a986e00e
+
+pkgname = git-extras
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25005994fe1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Thomas Jost <schnouki+aur@schnouki.net>
+pkgname=git-extras
+pkgver=0.9.0
+_pkgtag=948308b
+pkgrel=1
+pkgdesc="GIT utilities -- repo summary, commit counting, repl, changelog population and more"
+arch=(any)
+url="http://github.com/visionmedia/git-extras"
+license=('unknown')
+depends=('git' 'bash')
+makedepends=('ronn')
+source=(git-extras-$pkgver.tar.gz::https://github.com/visionmedia/${pkgname}/tarball/${pkgver})
+md5sums=('b27235c1a3eaa18ba2f91e4a56a6c527')
+sha256sums=('926ec2c50930e01f461a11eac13a16fd9fb91b852b67d7766810a5c5a986e00e')
+
+build() {
+ cd "$srcdir/visionmedia-$pkgname-$_pkgtag"
+ sed -i 's! /etc! $(PREFIX)/etc!g' Makefile
+
+ make docs
+
+}
+
+package() {
+ cd "$srcdir/visionmedia-$pkgname-$_pkgtag"
+
+ make PREFIX="$pkgdir/usr" install
+}
+
+# vim:set ts=2 sw=2 et: