summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Dziedzic2013-05-27 18:04:58 +0000
committerEli Schwartz2015-06-09 01:22:16 -0500
commitd021b4362a85265aa9ea344b7a949aeaeea85ec3 (patch)
tree1250a50b26e3cf66e98ddfaad5750c852c18ac8c
parent8444fc46d1faa8c2dd4f1737318c28ec2ab36d6b (diff)
downloadaur-d021b4362a85265aa9ea344b7a949aeaeea85ec3.tar.gz
upgpkg: git-extras 1.8.0-1
Imported old history from aur-mirror: updated on Mon May 27 18:04:57 UTC 2013 filter-branch: add .SRCINFO
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 370cd4a820f6..e5e6de3a09d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = git-extras
pkgdesc = GIT utilities -- repo summary, commit counting, repl, changelog population and more
- pkgver = 1.7.0
+ pkgver = 1.8.0
pkgrel = 1
url = http://github.com/visionmedia/git-extras
arch = any
license = custom:MIT
depends = git
depends = bash
- source = git-extras-1.7.0.tar.gz::https://github.com/visionmedia/git-extras/tarball/1.7.0
- md5sums = f0bdcecbc4d403937d175b2ebeb6df53
- sha256sums = 270e941af5a437c98e96dab0bd86e1dfa908a14dcd769536dadebe9584240b85
+ source = https://github.com/visionmedia/git-extras/archive/1.8.0.tar.gz
+ md5sums = 3f05a8ea87afa6780eece3d34a690ee5
+ sha256sums = 80ef21860809167324828da90d9cafff4f49c79096c63e0d7d104d0e6db849ff
pkgname = git-extras
diff --git a/PKGBUILD b/PKGBUILD
index f8de79120fa4..85540e88316a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
-# Maintainer: Thomas Jost <schnouki+aur@schnouki.net>
+# Maintainer: Stefan Tatschner <stefan.tatschner@gmail.com>
pkgname=git-extras
-pkgver=1.7.0
+pkgver=1.8.0
pkgrel=1
pkgdesc="GIT utilities -- repo summary, commit counting, repl, changelog population and more"
arch=(any)
url="http://github.com/visionmedia/git-extras"
license=('custom:MIT')
depends=('git' 'bash')
-source=(git-extras-${pkgver}.tar.gz::https://github.com/visionmedia/${pkgname}/tarball/${pkgver})
-md5sums=('f0bdcecbc4d403937d175b2ebeb6df53')
-sha256sums=('270e941af5a437c98e96dab0bd86e1dfa908a14dcd769536dadebe9584240b85')
+source="https://github.com/visionmedia/${pkgname}/archive/${pkgver}.tar.gz"
+md5sums=('3f05a8ea87afa6780eece3d34a690ee5')
+sha256sums=('80ef21860809167324828da90d9cafff4f49c79096c63e0d7d104d0e6db849ff')
package() {
- cd "$srcdir"/visionmedia-"$pkgname"-*
-
+ cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" PREFIX="/usr" install
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ #install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et: