summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2020-03-26 12:08:42 -0400
committerEli Schwartz2020-03-26 12:08:42 -0400
commitf0504acd69936c0eec9298921f664b4da088a100 (patch)
treee07fe453cf646c4d9d187d07501935d8f288a900
parent931cdd808f7a6e016310352abb632596893e7bc0 (diff)
downloadaur-f0504acd69936c0eec9298921f664b4da088a100.tar.gz
git-extras*/: make sure the PKGBUILD runs non-interactively
The Makefile has a "feature" where it checks the user's gitconfig to see if there are aliases which match installed commands. If there are, it will interactively prompt the user to decide whether to install them anyway (defaulting to "yes"). This is a package, so obviously we want to install it. But a PKGBUILD is supposed to run non-interactively, so prevent the question from even being raised. We do this by setting the GIT_CONFIG variable to /dev/null, preventing any other gitconfig files from being read.
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 848f9e8ec252..589a8df9165f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,6 +17,9 @@ b2sums=('279f0476c2ec6f30531d77d5c348bc6c0a823a622f7ec96ae65b1b2861a7c3ab1bf66eb
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # avoid annoying interactive prompts if an alias is in your gitconfig
+ export GIT_CONFIG=/dev/null
make DESTDIR="${pkgdir}" PREFIX=/usr SYSCONFDIR=/etc install
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}