summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCoelacanthus2021-03-15 18:32:35 +0800
committerCoelacanthus2021-03-15 18:32:35 +0800
commit5d840259c551766b498ba3605ba03a9275a9e319 (patch)
treef9e0c6aa9065d66dfae5a4c41277a9afd5b666fe
downloadaur-5d840259c551766b498ba3605ba03a9275a9e319.tar.gz
feat: init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4097e7a6c8fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = git-grc
+ pkgdesc = Semantic git commits tool. use rust to rewrite the main features of git-cz.
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/sdttttt/gcr
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ depends = gcc-libs
+ depends = git
+ source = gcr-1.1.0.tar.gz::https://github.com/sdttttt/gcr/archive/v1.1.0.tar.gz
+ b2sums = fffc7220a9c00baffe9e489de5cf37b13a5d57d72d29ee1c8bdcc285c5ac5a1564704627a192675568c75cf8f6c390737fcba106146477c24afc5b812eb81737
+
+pkgname = git-grc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3fa67960254
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Coelacanthus <coelacanthus@outlook.com>
+
+# rename for same name package in [community]
+pkgname=git-grc
+_pkgname=gcr
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Semantic git commits tool. use rust to rewrite the main features of git-cz."
+#epoch=0
+arch=('i686' 'x86_64')
+url="https://github.com/sdttttt/gcr"
+license=(MIT)
+depends=('gcc-libs'
+ 'git'
+ )
+makedepends=(cargo)
+optdepends=()
+source=($_pkgname-$pkgver.tar.gz::https://github.com/sdttttt/$_pkgname/archive/v$pkgver.tar.gz)
+b2sums=('fffc7220a9c00baffe9e489de5cf37b13a5d57d72d29ee1c8bdcc285c5ac5a1564704627a192675568c75cf8f6c390737fcba106146477c24afc5b812eb81737')
+
+prepare() {
+ return 0
+}
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ cargo install --no-track --locked --all-features --root "$pkgdir/usr/" --path .
+ #ln -sf "$pkgdir/usr/bin/grc" "$pkgdir/usr/bin/git-cz"
+ ln -sf "$pkgdir/usr/bin/grc" "$pkgdir/usr/bin/git-grc"
+}
+
+# vim:set ts=2 sw=2 et:
+