summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuietMisdreavus2020-06-12 07:49:35 -0600
committerQuietMisdreavus2020-06-12 07:49:35 -0600
commit8e0c7e753b9f5c380c8365450a3272e7ce9d9bc3 (patch)
tree521f20f3b4c15f95d85f0e5264b836544cafe8ae
parent1bfed7aa55cf5181309fb5d29c3a7c6191938c34 (diff)
downloadaur-8e0c7e753b9f5c380c8365450a3272e7ce9d9bc3.tar.gz
don't package the txt files, don't blanket-disable strip
the package step has been simplified based on suggestions from the forum, to bypass the `noextract` thing i was doing previously and instead properly using the `install` command to copy over the html files
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 5 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca9fc567ed8d..d11fab86e34b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = git-htmldocs
pkgdesc = HTML documentation files for Git
pkgver = 2.27.0
- pkgrel = 1
+ pkgrel = 2
url = https://git-scm.com/
arch = any
license = GPL2
depends = git
- noextract = git-htmldocs-2.27.0.tar.xz
- options = !strip
source = https://www.kernel.org/pub/software/scm/git/git-htmldocs-2.27.0.tar.xz
source = https://www.kernel.org/pub/software/scm/git/git-htmldocs-2.27.0.tar.sign
validpgpkeys = 96E07AF25771955980DAD10020D04E5A713660A7
diff --git a/PKGBUILD b/PKGBUILD
index 5f0abdeb1f9f..a82ff108c227 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Victoria Mitchell <victoria@quietmisdreavus.net>
pkgname=git-htmldocs
pkgver=2.27.0
-pkgrel=1
+pkgrel=2
pkgdesc="HTML documentation files for Git"
arch=('any')
url="https://git-scm.com/"
@@ -14,22 +14,10 @@ optdepends=()
source=("https://www.kernel.org/pub/software/scm/git/$pkgname-$pkgver.tar."{xz,sign})
sha256sums=('ffa91681b6a8f558745924b1dbb76d604c9e52b27c525c6bd470c0123f7f4af3'
'SKIP')
-# all of the files in the archive can be extracted directly into the documentation dir, so extract
-# it manually
-noextract=("$pkgname-$pkgver.tar.xz")
validpgpkeys=('96E07AF25771955980DAD10020D04E5A713660A7') # Junio C Hamano
-options=(!strip) # there are no binaries in the archive to strip
-
-prepare() {
- mkdir -p "$srcdir/$pkgname-$pkgver"
- bsdtar -xf "$pkgname-$pkgver.tar.xz" -C "$srcdir/$pkgname-$pkgver"
-
- # the files in the archive all have mode 600 (folders 700) so reset those before copying in
- find "$srcdir/$pkgname-$pkgver" -type d -exec chmod 755 \{\} \+
- find "$srcdir/$pkgname-$pkgver" -type f -exec chmod 644 \{\} \+
-}
package() {
- mkdir -p "$pkgdir"/usr/share/doc
- cp -a -r "$srcdir/$pkgname-$pkgver" "$pkgdir"/usr/share/doc/git-doc
+ install -Dm644 -t "$pkgdir/usr/share/doc/git-doc" *.html
+ install -Dm644 -t "$pkgdir/usr/share/doc/git-doc/howto" howto/*.html
+ install -Dm644 -t "$pkgdir/usr/share/doc/git-doc/technical" technical/*.html
}