summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsomini2019-03-28 16:01:09 +0000
committersomini2019-03-28 16:01:09 +0000
commit2e688058a5dcfc13f87ca8a9d9f6f7e44c47dfd8 (patch)
tree2f7f9fc4144716e6693df10d470111e096d0c0e7
downloadaur-2e688058a5dcfc13f87ca8a9d9f6f7e44c47dfd8.tar.gz
Initial release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2dc88aa994a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = git-identity-git
+ pkgdesc = Manage your identity in Git
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/madx/git-identity
+ arch = any
+ license = custom:WTFPL
+ depends = git
+ optdepends = zsh: for zsh completion
+ provides = git-identity
+ conflicts = git-identity
+ source = git-identity-git::git+https://github.com/madx/git-identity.git#branch=master
+ md5sums = SKIP
+
+pkgname = git-identity-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1899595f942
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: somini <dev@somini.xyz>
+_pkgname=git-identity
+pkgname=$_pkgname-git
+pkgver=latest
+pkgrel=1
+pkgdesc="Manage your identity in Git"
+arch=('any')
+url="https://github.com/madx/git-identity"
+license=('custom:WTFPL')
+depends=('git')
+# makedepends=()
+# checkdepends=()
+optdepends=('zsh: for zsh completion')
+provides=('git-identity')
+conflicts=('git-identity')
+source=("$pkgname::git+https://github.com/madx/git-identity.git#branch=master")
+md5sums=('SKIP')
+
+package() {
+ cd "$pkgname"
+ install -D git-identity -t "$pkgdir/usr/bin"
+
+ # License
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # Completions
+ install -Dm644 git-identity.bash-completion "$pkgdir/usr/share/bash-completion/git-identity"
+ install -Dm644 git-identity.zsh-completion "$pkgdir/usr/share/zsh/site-functions/_git-identity"
+}