summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-10-01 13:11:09 -0500
committerLuis Martinez2022-10-01 13:11:09 -0500
commitc5895a3604291dba41232e50ef1432e5ca7cbc0e (patch)
tree5aacec0a739de47a8745b47de82a0ec9325a2484
parenta2d140cc7d3a15d6905b5d484369d2da276b0a8a (diff)
downloadaur-c5895a3604291dba41232e50ef1432e5ca7cbc0e.tar.gz
update to 1.2.1
-rw-r--r--.SRCINFO10
-rw-r--r--CHANGELOG.md29
-rw-r--r--PKGBUILD33
3 files changed, 49 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83cf7fa91040..7dc0d82be062 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = git-ignore
pkgdesc = Quickly and easily list and fetch .gitignore templates from gitignore.io
- pkgver = 1.2.0
- pkgrel = 0
+ pkgver = 1.2.1
+ pkgrel = 1
url = https://github.com/sondr3/git-ignore
changelog = CHANGELOG.md
arch = x86_64
license = GPL3
makedepends = cargo
- makedepends = git
depends = gcc-libs
- source = git-ignore::git+https://github.com/sondr3/git-ignore#tag=v1.2.0
- sha256sums = SKIP
+ options = !lto
+ source = git-ignore-1.2.1.tar.gz::https://github.com/sondr3/git-ignore/archive/v1.2.1.tar.gz
+ sha256sums = 893061fa27b3a970fada4642f64eebed3a8c0c28a6a8b82c2eb8da6b68257710
pkgname = git-ignore
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 05203779200d..8f809a8683c1 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,9 +1,36 @@
+## v1.2.1
+
+> 2022-10-01
+
+## Summary
+
+Minor patch release with a single bug fix, with mostly behind the scenes package
+updates and upgrades.
+
+### Commits
+- [[`8d5a8cb`](https://github.com/sondr3/git-ignore)] Upgrade dependencies, clap to v4
+- [[`214f364`](https://github.com/sondr3/git-ignore)] Move to dtolnay/rust-toolchain for CI
+- [[`7e366f4`](https://github.com/sondr3/git-ignore)] Remove dependabot crates updates, upgrade packages
+- [[`46cc220`](https://github.com/sondr3/git-ignore)] Upgrade packages
+- [[`58a2ab8`](https://github.com/sondr3/git-ignore)] Upgrade packages
+- [[`8b0b4e0`](https://github.com/sondr3/git-ignore)] And release CI copying wrong assets
+- [[`f5d295e`](https://github.com/sondr3/git-ignore)] Add git-ignore AUR package
+- [[`e1c3c78`](https://github.com/sondr3/git-ignore)] Update CI versions
+- [[`79b10e5`](https://github.com/sondr3/git-ignore)] Add clap_mangen to build man pages, update build.rs
+- [[`40e8d11`](https://github.com/sondr3/git-ignore)] Update packages, fix deprecations
+- [[`684c360`](https://github.com/sondr3/git-ignore)] Add dependabot for GitHub Actions, Rust packages
+- [[`25bb013`](https://github.com/sondr3/git-ignore)] Fix wrong extension for Zig
+- [[`6e1d4e0`](https://github.com/sondr3/git-ignore)] Mention @sestrella in CHANGELOG [ci skip]
+- [[`584325b`](https://github.com/sondr3/git-ignore)] Unfuck publish pipeline
+- [[`df3ff6a`](https://github.com/sondr3/git-ignore)] Fix the release action, whoops
+
## 1.2.0
> 2021-12-05
The biggest release yet! From automatically recognizing templates based on files
-in your current directory to custom aliases and templates!
+in your current directory to custom aliases and templates! Huge thanks to
+[`sestrella`](https://github.com/sestrella) for contributing the automatic matching functionality.
- **Automatic**: When using the `-a/--auto`, `git-ignore` will automatically create `.gitignore`
templates by matching against files in your current directory.
diff --git a/PKGBUILD b/PKGBUILD
index 77f95a3d0344..299f463a85f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,44 +2,43 @@
# Co-Maintainer: Sondre Nilsen <echo "bmlsc2VuLnNvbmRyZUBnbWFpbC5jb20K" | base64 -d>
pkgname=git-ignore
-pkgver=1.2.0
-pkgrel=0
+pkgver=1.2.1
+pkgrel=1
pkgdesc="Quickly and easily list and fetch .gitignore templates from gitignore.io"
arch=('x86_64')
url="https://github.com/sondr3/git-ignore"
license=('GPL3')
-conflics=('git-ignore-bin')
depends=('gcc-libs')
-makedepends=('cargo' 'git')
+makedepends=('cargo')
+options=('!lto')
changelog=CHANGELOG.md
-source=("$pkgname::git+$url#tag=v$pkgver")
-sha256sums=('SKIP')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('893061fa27b3a970fada4642f64eebed3a8c0c28a6a8b82c2eb8da6b68257710')
prepare() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
cargo build --release --frozen --all-features
}
check() {
export RUSTUP_TOOLCHAIN=stable
- cd "$pkgname"
- cargo test --release --frozen --all-features
+ cd "$pkgname-$pkgver"
+ cargo test --frozen --all-features
}
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
install -D "target/release/$pkgname" -t "$pkgdir/usr/bin/"
-
- install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
- install -Dm 644 "assets/git-ignore.1" "$pkgdir/usr/share/man/man1/git-ignore.1"
- install -Dm 644 "assets/git-ignore.bash" "$pkgdir/usr/share/bash-completion/completions/git-ignore"
- install -Dm 644 "assets/git-ignore.fish" "$pkgdir/usr/share/fish/vendor_completions.d/git-ignore.fish"
- install -Dm 644 "assets/_git-ignore" "$pkgdir/usr/share/zsh/site-functions/_git-ignore"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ install -Dm644 "target/assets/git-ignore.1" "$pkgdir/usr/share/man/man1/git-ignore.1"
+ install -Dm644 "target/assets/git-ignore.bash" "$pkgdir/usr/share/bash-completion/completions/git-ignore"
+ install -Dm644 "target/assets/git-ignore.fish" "$pkgdir/usr/share/fish/vendor_completions.d/git-ignore.fish"
+ install -Dm644 "target/assets/_git-ignore" "$pkgdir/usr/share/zsh/site-functions/_git-ignore"
}