summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSondre Nilsen2019-04-18 23:30:36 +0200
committerSondre Nilsen2019-04-18 23:30:36 +0200
commit3ba2775c326bd264f75e6a6d47789d4923a66bb5 (patch)
tree06ed9cbb8b1ab190680d6dd1b3bb462fdadf437c
downloadaur-3ba2775c326bd264f75e6a6d47789d4923a66bb5.tar.gz
Add prerelease version for testing
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3670f53fae0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = git-ignore-bin
+ pkgdesc = Quickly and easily list and fetch .gitignore templates from www.gitignore.io
+ pkgver = 1.0.0-pre
+ pkgrel = 1
+ url = https://github.com/sondr3/git-ignore
+ arch = x86_64
+ license = GPL3
+ provides = git-ignore
+ conflicts = git-ignore
+ source_x86_64 = https://github.com/sondr3/git-ignore/releases/download/v${pkgver}/${pkgname/-bin/}-v${pkgver}-x86_64-unknown-linux-musl.tar.gz
+ sha1sums_x86_64 = 27be177b769d1f40cdd2628ebb6961279d7f2762
+
+pkgname = git-ignore-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9845cbcf2659
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Sondre Nilsen <echo "bmlsc2VuLnNvbmRyZUBnbWFpbC5jb20K" | base64 -d>
+
+pkgname=git-ignore-bin
+pkgver=1.0.0-pre
+pkgrel=1
+pkgdesc="Quickly and easily list and fetch .gitignore templates from www.gitignore.io"
+url="https://github.com/sondr3/git-ignore"
+arch=('x86_64')
+license=('GPL3')
+provides=('git-ignore')
+conflicts=('git-ignore')
+source_x86_64=('https://github.com/sondr3/git-ignore/releases/download/v${pkgver}/${pkgname/-bin/}-v${pkgver}-x86_64-unknown-linux-musl.tar.gz')
+sha1sums_x86_64=('27be177b769d1f40cdd2628ebb6961279d7f2762')
+
+package() {
+ install -Dm755 git-ignore "$pkgdir/usr/bin/git-ignore"
+ install -Dm644 git-ignore.1 "$pkgdir/usr/share/man/man1/git-ignore.1"
+}