summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSondre Nilsen2021-12-09 15:41:29 +0100
committerSondre Nilsen2021-12-09 15:41:29 +0100
commite4cc49b417d741cc41f4c2631d7429b1b1df489e (patch)
treec4061d913630e24d05eef0dfaf50fa83ac4b06f0
parentfe9b33c82efecd467a2e0a3a54432b83206041f9 (diff)
downloadaur-e4cc49b417d741cc41f4c2631d7429b1b1df489e.tar.gz
upgpkg: git-ignore-bin 1.2.0-0
Update git-ignore-bin to v1.2.0
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD8
3 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9833e82605d4..4ff9e29b85bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = git-ignore-bin
pkgdesc = Quickly and easily list and fetch .gitignore templates from www.gitignore.io
- pkgver = 1.1.2
+ pkgver = 1.2.0
pkgrel = 0
url = https://github.com/sondr3/git-ignore
arch = x86_64
license = GPL3
provides = git-ignore
conflicts = git-ignore
- source_x86_64 = https://github.com/sondr3/git-ignore/releases/download/v1.1.2/git-ignore-x86_64-unknown-linux-musl.tar.gz
- sha256sums_x86_64 = 314c4e47723b79fc4b9973219db43187a4abf3d5d2c3c83cfa23abc669c404a9
+ source_x86_64 = https://github.com/sondr3/git-ignore/releases/download/v1.2.0/git-ignore-x86_64-unknown-linux-musl.tar.gz
+ sha256sums_x86_64 = 5a3a4e2c94e2645b56e021338d94236bf730d4f36dac1cb31390b8b8c4016cf8
pkgname = git-ignore-bin
diff --git a/.gitignore b/.gitignore
index 8583debd9ce8..08f9b555c892 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,7 @@
-
+*
+!.SRCINFO
+!PKGBUILD
+!.gitignore
### Created by https://www.gitignore.io
### ArchLinuxPackages ###
diff --git a/PKGBUILD b/PKGBUILD
index 000d96a2390a..2f574d0ec35c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sondre Nilsen <echo "bmlsc2VuLnNvbmRyZUBnbWFpbC5jb20K" | base64 -d>
pkgname=git-ignore-bin
-pkgver=1.1.2
+pkgver=1.2.0
pkgrel=0
pkgdesc="Quickly and easily list and fetch .gitignore templates from www.gitignore.io"
url="https://github.com/sondr3/git-ignore"
@@ -10,9 +10,13 @@ license=('GPL3')
provides=('git-ignore')
conflicts=('git-ignore')
source_x86_64=("https://github.com/sondr3/git-ignore/releases/download/v${pkgver}/${pkgname/-bin/}-x86_64-unknown-linux-musl.tar.gz")
-sha256sums_x86_64=('314c4e47723b79fc4b9973219db43187a4abf3d5d2c3c83cfa23abc669c404a9')
+sha256sums_x86_64=('5a3a4e2c94e2645b56e021338d94236bf730d4f36dac1cb31390b8b8c4016cf8')
package() {
install -Dm755 git-ignore "$pkgdir/usr/bin/git-ignore"
install -Dm644 git-ignore.1 "$pkgdir/usr/share/man/man1/git-ignore.1"
+
+ install -Dm644 git-ignore.bash "$pkgdir/usr/share/bash-completion/completions/git-ignore"
+ install -Dm644 git-ignore.fish "$pkgdir/usr/share/fish/vendor_completions.d/git-ignore.fish"
+ install -Dm644 _git-ignore "$pkgdir/usr/share/zsh/site-functions/_git-ignore"
}