summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2021-05-10 16:16:17 +0200
committerKr1ss2021-05-10 16:16:17 +0200
commit1c4285ecc9dce3d87a6dc3bca8fcdc9c9068a839 (patch)
tree171c007b0e79aade12ae2831c592c648e987e1e5
parentf9dd8e3366e43711b9ff3f4d6b81012a98b16f93 (diff)
downloadaur-1c4285ecc9dce3d87a6dc3bca8fcdc9c9068a839.tar.gz
fix dependencies and cargo flags; update changelog
-rw-r--r--.SRCINFO5
-rw-r--r--CHANGELOG.md7
-rw-r--r--PKGBUILD17
3 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 687045ac61b5..e492fecf2c83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = git-interactive-rebase-tool-git
pkgdesc = An improved sequence editor for interactive git-rebase
- pkgver = 2.0.0.r569.badf080
+ pkgver = 2.1.0.r583.a179df6
pkgrel = 1
url = https://gitrebasetool.mitmaro.ca
install = git-interactive-rebase-tool.install
changelog = CHANGELOG.md
arch = x86_64
license = GPL3
+ makedepends = git
makedepends = rust
- depends = git
+ depends = libgit2
provides = git-interactive-rebase-tool
conflicts = git-interactive-rebase-tool
options = zipman
diff --git a/CHANGELOG.md b/CHANGELOG.md
index a924f18f1cbb..5de422fcd904 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -3,7 +3,7 @@ All notable changes to this project will be documented in this file.
The format is based on [Keep a Changelog](http://keepachangelog.com/) and this project adheres to [Semantic Versioning](http://semver.org/).
-## [Unreleased]
+## [2.1.0] - 2021-04-20
### Added
- Label and description to commit edit ([#429](https://github.com/MitMaro/git-interactive-rebase-tool/pull/429))
@@ -13,6 +13,8 @@ The format is based on [Keep a Changelog](http://keepachangelog.com/) and this p
- Support for multiple key bindings per configuration ([#437](https://github.com/MitMaro/git-interactive-rebase-tool/pull/437))
- Open external editor from visual mode ([#442](https://github.com/MitMaro/git-interactive-rebase-tool/pull/442))
- Delete selected lines from the todo list ([#443](https://github.com/MitMaro/git-interactive-rebase-tool/pull/443))
+- Insert new exec, commit, label, reset or merge line ([#454](https://github.com/MitMaro/git-interactive-rebase-tool/pull/454), [#458](https://github.com/MitMaro/git-interactive-rebase-tool/pull/458))
+- Support home and end in list view ([#455](https://github.com/MitMaro/git-interactive-rebase-tool/pull/455))
### Fixed
- Most modifier key combinations could not be used as key bindings ([#435](https://github.com/MitMaro/git-interactive-rebase-tool/pull/435))
@@ -151,7 +153,8 @@ The format is based on [Keep a Changelog](http://keepachangelog.com/) and this p
### Added
- Initial project release
-[Unreleased]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/2.0.0...HEAD
+[Unreleased]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/2.1.0...HEAD
+[2.1.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/2.0.0...2.1.0
[2.0.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/1.2.1...2.0.0
[1.2.1]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/1.2.0...1.2.1
[1.2.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/1.1.0...1.2.0
diff --git a/PKGBUILD b/PKGBUILD
index eab4d257abfc..918fc81eebca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,11 +8,11 @@ _name="${_pkgname#git-}"
pkgver() {
cd "$_pkgname"
- printf '%s.r%s.%s' \
+ printf %s.r%s.%s \
"$(git tag -l | grep -P '.+\..+\.\d+' | sed -r 's/([0-9\.]+)(-.+)?/\1/g' | sort -Vr | sed 1q)" \
"$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-pkgver=2.0.0.r569.badf080
+pkgver=2.1.0.r583.a179df6
pkgrel=1
pkgdesc='An improved sequence editor for interactive git-rebase'
@@ -23,8 +23,8 @@ license=('GPL3')
provides=("$_pkgname")
conflicts=("$_pkgname")
-makedepends=('rust')
-depends=('git')
+makedepends=('git' 'rust')
+depends=('libgit2')
options=('zipman')
@@ -44,7 +44,12 @@ build() {
if type -P rustup && ! rustup default &>/dev/null; then
rustup default stable
fi
- cargo build --release
+ cargo build --release --locked
+}
+
+check() {
+ cd "$_pkgname"
+ cargo test --release --locked
}
package() {
@@ -53,7 +58,7 @@ package() {
install -Dm644 {,readme/}*.md -t"$pkgdir/usr/share/doc/$_pkgname/"
install -Dm644 docs/assets/images/* -t"$pkgdir/usr/share/doc/$_pkgname/images/"
install -Dm644 LICENSE -t"$pkgdir/usr/share/licenses/$_pkgname/"
- install -Dm644 src/$_name.1 -t"$pkgdir/usr/share/man/man1/"
+ install -Dm644 "src/$_name.1" -t"$pkgdir/usr/share/man/man1/"
}