summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2019-10-07 03:20:23 +0200
committerKr1ss2019-10-07 03:20:23 +0200
commit1e7353f611a27bc48fa9369db53ebf3dfe5a77d4 (patch)
tree4408956e88fc5f329dae475740da2289ccc7e5d9
parent2a17252c3c117c80b11612912d514684f714a564 (diff)
downloadaur-1e7353f611a27bc48fa9369db53ebf3dfe5a77d4.tar.gz
add changelog & documentation, fix license & url
-rw-r--r--.SRCINFO9
-rw-r--r--CHANGELOG.md111
-rw-r--r--PKGBUILD17
3 files changed, 125 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 436f7f432421..eee6bed19c41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = git-interactive-rebase-tool-git
- pkgdesc = Native full feature terminal based sequence editor for interactive git rebase
- pkgver = 1.1.0.r243.ab379e3
+ pkgdesc = An improved sequence editor for interactive git-rebase
+ pkgver = 1.1.0.r244.0074a99
pkgrel = 1
- url = https://github.com/MitMaro/git-interactive-rebase-tool
+ url = https://gitrebasetool.mitmaro.ca/
install = git-interactive-rebase-tool.install
+ changelog = CHANGELOG.md
arch = x86_64
- license = custom:ISC
+ license = GPL3
makedepends = rust
depends = git
provides = git-interactive-rebase-tool
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..c4311681b9cb
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,111 @@
+# Change Log
+All notable changes to this project will be documented in this file.
+
+The format is based on [Keep a Changelog](http://keepachangelog.com/)
+and this project adheres to [Semantic Versioning](http://semver.org/).
+
+## [Unreleased] - 2019-08-15
+
+### Added
+- Support for 256-color terminals
+- Highlight of selected line(s) on 256-color terminals
+
+### Fixed
+- Missing ncursesw dependency listing for deb build
+- Performance issue with show commit
+
+### Removed
+- Unused `errorColor` configuration
+
+## [1.1.0] - 2019-08-15
+
+### Added
+- Add support for the break action
+- The command of an exec action can now be edited
+- Visual mode - change action and reorder with multiple selections
+- Configuration option for vertical spacing character
+- Configurable key bindings
+- Horizontal scrolling
+
+### Fixed
+- A noop rebase will no longer return a non-zero status code
+
+## [1.0.0] - 2019-04-10
+
+### Added
+- Support for unicode characters
+- Horizontal and vertical overflow support
+
+### Changed
+- Show git now uses libgit2 instead of external command
+
+## [0.7.0] - 2018-10-28
+
+### Added
+- Support git `core.commentChar` option
+- Configuration of colors
+- Support for the exec action
+- Auto-select next line configuration
+- Prepend application name to error messages
+
+### Fixed
+- Windows creating a new window on run (hopefully)
+- Resize not handled in all cases
+
+## [0.6.0] - 2018-02-08
+
+### Added
+- man page
+
+## [0.5.0] - 2017-12-29
+
+### Added
+- `--version` and `-v` options to print current version
+
+## [0.4.0] - 2017-02-11
+
+### Added
+- Support for scrolling
+- Support for page up and page down
+
+### Fixed
+- Crash on noop rebases
+
+## [0.3.0] - 2017-01-21
+### Changed
+- Cleaned up help
+
+### Added
+- Build setup
+- Documentation with `README.md`
+- LICENSE
+
+### Changed
+- `Cargo.toml` cleaned up
+
+## [0.2.0] - 2017-01-07
+### Added
+- `Q` key that immediately aborts
+- `W` key that immediately resumes rebase
+
+### Fixed
+- Fixed actions for `j` and `k` keys
+
+### Changed
+- Complete rewrite of the project
+- Removed `exec` support
+- Friendlier selection indicator
+
+## 0.1.0 - 2016-12-22
+### Added
+- Initial project release
+
+[Unreleased]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/1.1.0...HEAD
+[1.1.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/1.0.0...1.1.0
+[1.0.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/0.7.0...1.0.0
+[0.7.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/0.6.0...0.7.0
+[0.6.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/0.5.0...0.6.0
+[0.5.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/0.4.0...0.5.0
+[0.4.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/0.3.0...0.4.0
+[0.3.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/0.2.0...0.3.0
+[0.2.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/0.1.0...0.2.0
diff --git a/PKGBUILD b/PKGBUILD
index f03a7e1cba3e..bfbf630e9214 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,13 +9,13 @@ pkgver() {
"$(git tag -l | grep -P '.+\..+\.\d+' | sed -r 's/([0-9\.]+)(-.+)?/\1/g' | sort -Vr | sed 1q)" \
"$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-pkgver=1.1.0.r243.ab379e3
+pkgver=1.1.0.r244.0074a99
pkgrel=1
-pkgdesc='Native full feature terminal based sequence editor for interactive git rebase'
+pkgdesc='An improved sequence editor for interactive git-rebase'
arch=('x86_64')
-url="https://github.com/MitMaro/${pkgname%-git}"
-license=('custom:ISC')
+url=https://gitrebasetool.mitmaro.ca/
+license=('GPL3')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -26,7 +26,8 @@ makedepends=('rust')
options=('zipman')
install="${pkgname%-git}.install"
-source=("git+$url.git")
+changelog=CHANGELOG.md
+source=("git+https://github.com/MitMaro/${pkgname%-git}.git")
sha256sums=('SKIP')
build() {
@@ -41,10 +42,10 @@ build() {
package() {
cd "${pkgname%-git}"
- install -dm755 "$pkgdir"/usr/{bin,share/{man/man1,licenses/"${pkgname%-git}"}}
+ install -dm755 "$pkgdir"/usr/{bin,share/{doc,man/man1,licenses/"${pkgname%-git}"}}
install -m755 target/release/interactive-rebase-tool -t"$pkgdir/usr/bin/"
- install -m644 src/interactive-rebase-tool.1 -t"$pkgdir/usr/share/man/man1/"
- install -m644 LICENSE -t"$pkgdir/usr/share/licenses/${pkgname%-git}/"
+ install -m644 {README,CHANGELOG,CODE_OF_CONDUCT}.md -t"$pkgdir/usr/share/doc/"
+ install -m644 src/interactive-rebase-tool.1 -t"$pkgdir/usr/share/man/man1/"
}