summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2021-03-12 15:35:47 +0100
committerKr1ss2021-03-12 15:35:47 +0100
commit26dc97d21a3a9ff193ce71550ddee17af011a8e6 (patch)
treeefe9b7d85e54b4e9b2de60fc35214553f7d47fd9
parent6722c94d5fa76ab70c1e733b480abe3a556f5f51 (diff)
downloadaur-26dc97d21a3a9ff193ce71550ddee17af011a8e6.tar.gz
update changelog
-rw-r--r--.SRCINFO3
-rw-r--r--CHANGELOG.md17
-rw-r--r--PKGBUILD32
3 files changed, 33 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f9afada153a..c66692f13035 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = git-interactive-rebase-tool-git
pkgdesc = An improved sequence editor for interactive git-rebase
- pkgver = 2.0.0.r540.70a14d6
+ pkgver = 2.0.0.r563.8eef70b
pkgrel = 1
url = https://gitrebasetool.mitmaro.ca
install = git-interactive-rebase-tool.install
@@ -16,3 +16,4 @@ pkgbase = git-interactive-rebase-tool-git
sha256sums = SKIP
pkgname = git-interactive-rebase-tool-git
+
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 553efd90b016..9ae412241012 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -4,6 +4,19 @@ All notable changes to this project will be documented in this file.
The format is based on [Keep a Changelog](http://keepachangelog.com/)
and this project adheres to [Semantic Versioning](http://semver.org/).
+## [Unreleased]
+
+### Added
+- Label and description to commit edit
+- Basic support to merge rebasing
+- Modifier keys can now be provided in any order
+- Undo and redo changes to the todo list
+- Support for multiple key bindings per configuration
+- Open external editor from visual mode
+
+### Fixed
+- Most modifier key combinations could not be used as key bindings
+
## [2.0.0] - 2021-01-28
### Added
@@ -74,7 +87,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
- Horizontal and vertical overflow support
### Changed
-- Show git now uses libgit2 instead of external command
+- Show git now uses libgit2 instead of an external command
## [0.7.0] - 2018-10-28
@@ -138,7 +151,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
- Initial project release
[Unreleased]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/2.0.0...HEAD
-[Unreleased]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/1.2.1...2.0.0
+[2.0.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/1.2.1...2.0.0
[1.2.1]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/1.2.0...1.2.1
[1.2.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/1.1.0...1.2.0
[1.1.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/1.0.0...1.1.0
diff --git a/PKGBUILD b/PKGBUILD
index 34ddf7b23f5a..db6b11308a01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,16 @@
pkgname=git-interactive-rebase-tool-git
+_pkgname="${pkgname%-git}"
+_name="${_pkgname#git-}"
pkgver() {
- cd "${pkgname%-git}"
+ cd "$_pkgname"
printf '%s.r%s.%s' \
"$(git tag -l | grep -P '.+\..+\.\d+' | sed -r 's/([0-9\.]+)(-.+)?/\1/g' | sort -Vr | sed 1q)" \
"$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-pkgver=2.0.0.r540.70a14d6
+pkgver=2.0.0.r563.8eef70b
pkgrel=1
pkgdesc='An improved sequence editor for interactive git-rebase'
@@ -18,36 +20,34 @@ arch=('x86_64')
url=https://gitrebasetool.mitmaro.ca
license=('GPL3')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
makedepends=('rust')
depends=('git')
options=('zipman')
-install="${pkgname%-git}.install"
+install="$_pkgname.install"
changelog=CHANGELOG.md
-source=("git+https://github.com/MitMaro/${pkgname%-git}.git")
+source=("git+https://github.com/MitMaro/$_pkgname.git")
sha256sums=('SKIP')
build() {
- cd "${pkgname%-git}"
- if type -P rustup; then
- if ! rustup default &>/dev/null; then
- rustup default stable
- fi
+ cd "$_pkgname"
+ if type -P rustup && ! rustup default &>/dev/null; then
+ rustup default stable
fi
cargo build --release
}
package() {
- cd "${pkgname%-git}"
- install -Dm755 target/release/interactive-rebase-tool -t"$pkgdir/usr/bin/"
- install -Dm644 {README,CHANGELOG,CODE_OF_CONDUCT}.md -t"$pkgdir/usr/share/doc/${pkgname%-git}/"
- install -Dm644 LICENSE -t"$pkgdir/usr/share/licenses/${pkgname%-git}/"
- install -Dm644 src/interactive-rebase-tool.1 -t"$pkgdir/usr/share/man/man1/"
+ cd "$_pkgname"
+ install -Dm755 "target/release/$_name" -t"$pkgdir/usr/bin/"
+ install -Dm644 {,readme/}*.md -t"$pkgdir/usr/share/doc/$_pkgname/"
+ install -Dm644 LICENSE -t"$pkgdir/usr/share/licenses/$_pkgname/"
+ install -Dm644 src/$_name.1 -t"$pkgdir/usr/share/man/man1/"
}