summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2019-10-06 22:28:55 +0200
committerKr1ss2019-10-06 22:28:55 +0200
commit2a17252c3c117c80b11612912d514684f714a564 (patch)
treeaf5d82d3dc24b2639719c771a1144888807a6ab2
downloadaur-2a17252c3c117c80b11612912d514684f714a564.tar.gz
initial upload: 1.1.0.r243.ab379e3-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD51
-rw-r--r--git-interactive-rebase-tool.install13
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..436f7f432421
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = git-interactive-rebase-tool-git
+ pkgdesc = Native full feature terminal based sequence editor for interactive git rebase
+ pkgver = 1.1.0.r243.ab379e3
+ pkgrel = 1
+ url = https://github.com/MitMaro/git-interactive-rebase-tool
+ install = git-interactive-rebase-tool.install
+ arch = x86_64
+ license = custom:ISC
+ makedepends = rust
+ depends = git
+ provides = git-interactive-rebase-tool
+ conflicts = git-interactive-rebase-tool
+ options = zipman
+ source = git+https://github.com/MitMaro/git-interactive-rebase-tool.git
+ sha256sums = SKIP
+
+pkgname = git-interactive-rebase-tool-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f03a7e1cba3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/)
+# Contributor : Gabriel Guldner <gabriel at guldner dot eu>
+
+
+pkgname=git-interactive-rebase-tool-git
+pkgver() {
+ cd "${pkgname%-git}"
+ printf '%s.r%s.%s' \
+ "$(git tag -l | grep -P '.+\..+\.\d+' | sed -r 's/([0-9\.]+)(-.+)?/\1/g' | sort -Vr | sed 1q)" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+pkgver=1.1.0.r243.ab379e3
+pkgrel=1
+
+pkgdesc='Native full feature terminal based sequence editor for interactive git rebase'
+arch=('x86_64')
+url="https://github.com/MitMaro/${pkgname%-git}"
+license=('custom:ISC')
+
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+
+depends=('git')
+makedepends=('rust')
+
+options=('zipman')
+
+install="${pkgname%-git}.install"
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "${pkgname%-git}"
+ if type -P rustup; then
+ if ! rustup default &>/dev/null; then
+ rustup default stable
+ fi
+ fi
+ cargo build --release
+}
+
+package() {
+ cd "${pkgname%-git}"
+ install -dm755 "$pkgdir"/usr/{bin,share/{man/man1,licenses/"${pkgname%-git}"}}
+ install -m755 target/release/interactive-rebase-tool -t"$pkgdir/usr/bin/"
+ install -m644 src/interactive-rebase-tool.1 -t"$pkgdir/usr/share/man/man1/"
+ install -m644 LICENSE -t"$pkgdir/usr/share/licenses/${pkgname%-git}/"
+}
+
+
+# vim: ts=2 sw=2 et ft=PKGBUILD:
diff --git a/git-interactive-rebase-tool.install b/git-interactive-rebase-tool.install
new file mode 100644
index 000000000000..ae37701bf6f0
--- /dev/null
+++ b/git-interactive-rebase-tool.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo ""
+ echo "Configure git to use the rebase tool:"
+ echo "git config --global sequence.editor interactive-rebase-tool"
+ echo ""
+}
+
+post_remove() {
+ echo ""
+ echo "You have to remove the tool from the git configuration:"
+ echo "git config --global --unset sequence.editor"
+ echo ""
+}