summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2020-03-16 11:46:08 +0100
committerKr1ss2020-03-16 11:46:08 +0100
commit4806d6b8bb2bf46099da40c741f4e1cf2ecf7bb4 (patch)
treeee989039fc85f01dd5ff18d02f12825fcfb2ac32
parent56c242aaf492f12c54411659d744c671bd708d5a (diff)
downloadaur-4806d6b8bb2bf46099da40c741f4e1cf2ecf7bb4.tar.gz
update changelog
-rw-r--r--.SRCINFO4
-rw-r--r--CHANGELOG.md32
-rw-r--r--PKGBUILD4
-rw-r--r--git-interactive-rebase-tool.install10
4 files changed, 35 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01dbc96a0e25..54db795899e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = git-interactive-rebase-tool-git
pkgdesc = An improved sequence editor for interactive git-rebase
- pkgver = 1.1.0.r259.73c4fe3
- pkgrel = 2
+ pkgver = 1.2.1.r295.22374c2
+ pkgrel = 1
url = https://gitrebasetool.mitmaro.ca/
install = git-interactive-rebase-tool.install
changelog = CHANGELOG.md
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 80ac755ca351..2784df40d936 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -4,16 +4,34 @@ All notable changes to this project will be documented in this file.
The format is based on [Keep a Changelog](http://keepachangelog.com/)
and this project adheres to [Semantic Versioning](http://semver.org/).
-## [Unreleased] - 2019-10-07
+## [Unreleased] - 2020-03-14
+
+### Added
+- Added page up and down to help view
+- Added page up and down to show commit
+
+### Changed
+- Change page up and page down to scroll half the height of the view area
+
+## [1.2.1] - 2020-01-26
+
+### Fixed
+- ANSI color support broken on MacOS ([#219](https://github.com/MitMaro/git-interactive-rebase-tool/issues/219))
+
+## [1.2.0] - 2020-01-11
### Added
- Support for 256-color terminals
-- Highlight of selected line(s) on 256-color terminals
+- Highlight of selected line(s) on 256-color terminals ([#148](https://github.com/MitMaro/git-interactive-rebase-tool/issues/148)
+- Full support for external editor ([#60](https://github.com/MitMaro/git-interactive-rebase-tool/issues/60))
### Fixed
-- Missing ncursesw dependency listing for deb build
-- Performance issue with show commit
-- Visual mode index error when changing action or swapping lines
+- Missing ncursesw dependency listing for deb build ([#170](https://github.com/MitMaro/git-interactive-rebase-tool/issues/170))
+- Performance issue with show commit ([#167](https://github.com/MitMaro/git-interactive-rebase-tool/issues/167))
+- Visual mode index error when changing action or swapping lines ([195](https://github.com/MitMaro/git-interactive-rebase-tool/issues/195)))
+- Fixed crash with scrolling to max length
+- A empty rebase file now returns a zero exit code ([#197](https://github.com/MitMaro/git-interactive-rebase-tool/issues/197))
+- External editing loop when an external editor returns an empty file ([#196](https://github.com/MitMaro/git-interactive-rebase-tool/issues/196))
### Removed
- Unused `errorColor` configuration
@@ -101,7 +119,9 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Added
- Initial project release
-[Unreleased]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/1.1.0...HEAD
+[Unreleased]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/1.2.1...HEAD
+[1.2.1]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/1.2.0...1.2.1
+[1.2.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/1.1.0...1.2.0
[1.1.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/1.0.0...1.1.0
[1.0.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/0.7.0...1.0.0
[0.7.0]: https://github.com/MitMaro/git-interactive-rebase-tool/compare/0.6.0...0.7.0
diff --git a/PKGBUILD b/PKGBUILD
index 64537addac19..633161326752 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@ pkgver() {
"$(git tag -l | grep -P '.+\..+\.\d+' | sed -r 's/([0-9\.]+)(-.+)?/\1/g' | sort -Vr | sed 1q)" \
"$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-pkgver=1.1.0.r259.73c4fe3
-pkgrel=2
+pkgver=1.2.1.r295.22374c2
+pkgrel=1
pkgdesc='An improved sequence editor for interactive git-rebase'
arch=('x86_64')
diff --git a/git-interactive-rebase-tool.install b/git-interactive-rebase-tool.install
index ae37701bf6f0..e59b496946ea 100644
--- a/git-interactive-rebase-tool.install
+++ b/git-interactive-rebase-tool.install
@@ -1,13 +1,13 @@
post_install() {
- echo ""
+ echo
echo "Configure git to use the rebase tool:"
echo "git config --global sequence.editor interactive-rebase-tool"
- echo ""
+ echo
}
post_remove() {
- echo ""
- echo "You have to remove the tool from the git configuration:"
+ echo
+ echo "Remember to remove the tool from the git configuration:"
echo "git config --global --unset sequence.editor"
- echo ""
+ echo
}