summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2020-12-17 20:07:13 +0100
committerKr1ss2020-12-17 20:07:13 +0100
commit5714f95c2fa2d0fa7cdc0b33f48460ae74023d29 (patch)
tree5b2e857253e2b42ee937ef047951b6a1f9c093d2
parent4806d6b8bb2bf46099da40c741f4e1cf2ecf7bb4 (diff)
downloadaur-5714f95c2fa2d0fa7cdc0b33f48460ae74023d29.tar.gz
update changelog
-rw-r--r--.SRCINFO4
-rw-r--r--CHANGELOG.md20
-rw-r--r--PKGBUILD10
3 files changed, 26 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54db795899e9..537ad9c33792 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = git-interactive-rebase-tool-git
pkgdesc = An improved sequence editor for interactive git-rebase
- pkgver = 1.2.1.r295.22374c2
+ pkgver = 1.2.1.r510.a0c81f4
pkgrel = 1
- url = https://gitrebasetool.mitmaro.ca/
+ url = https://gitrebasetool.mitmaro.ca
install = git-interactive-rebase-tool.install
changelog = CHANGELOG.md
arch = x86_64
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 2784df40d936..ead9e16830ec 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -7,11 +7,27 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
## [Unreleased] - 2020-03-14
### Added
-- Added page up and down to help view
-- Added page up and down to show commit
+- A diff view to show commit
+- Page up and down to help view
+- Page up and down to show commit
+- Most missing key bindings for special keys
+- Builtin help for show commit
+- Number of files change in show commit
+- Number of total additions and deletions in show commit
+- The Git "diff.renames" and "diff.rename_limit" options are now respected during show commit
+- End and Home support during edit
+- Optional rollback on error or invalid file during external edit
### Changed
- Change page up and page down to scroll half the height of the view area
+- Improved error handling for executing external editor
+
+### Fixed
+- Scroll position resetting on resize
+- Unable to move edit edit cursor when `inputMoveLeft` or `inputMoveRight` were set to alphanumeric characters
+
+### Removed
+- Available actions footer from list and show commit views
## [1.2.1] - 2020-01-26
diff --git a/PKGBUILD b/PKGBUILD
index 633161326752..a2bf1e719a1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,26 @@
pkgname=git-interactive-rebase-tool-git
+
pkgver() {
cd "${pkgname%-git}"
printf '%s.r%s.%s' \
"$(git tag -l | grep -P '.+\..+\.\d+' | sed -r 's/([0-9\.]+)(-.+)?/\1/g' | sort -Vr | sed 1q)" \
"$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-pkgver=1.2.1.r295.22374c2
+pkgver=1.2.1.r510.a0c81f4
pkgrel=1
pkgdesc='An improved sequence editor for interactive git-rebase'
arch=('x86_64')
-url=https://gitrebasetool.mitmaro.ca/
+url=https://gitrebasetool.mitmaro.ca
license=('GPL3')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-depends=('git')
makedepends=('rust')
+depends=('git')
options=('zipman')
@@ -30,6 +31,7 @@ changelog=CHANGELOG.md
source=("git+https://github.com/MitMaro/${pkgname%-git}.git")
sha256sums=('SKIP')
+
build() {
cd "${pkgname%-git}"
if type -P rustup; then
@@ -44,7 +46,7 @@ package() {
cd "${pkgname%-git}"
install -Dm755 target/release/interactive-rebase-tool -t"$pkgdir/usr/bin/"
install -Dm644 {README,CHANGELOG,CODE_OF_CONDUCT}.md -t"$pkgdir/usr/share/doc/${pkgname%-git}/"
- install -Dm644 LICENSE THIRD_PARTY_LICENSES -t"$pkgdir/usr/share/licenses/${pkgname%-git}/"
+ install -Dm644 LICENSE -t"$pkgdir/usr/share/licenses/${pkgname%-git}/"
install -Dm644 src/interactive-rebase-tool.1 -t"$pkgdir/usr/share/man/man1/"
}