summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAner Andros2017-04-01 14:13:05 +0100
committerAner Andros2017-04-01 14:13:05 +0100
commit9ae09c3b3a832adfcbc747ef9b948d8ae4a84cec (patch)
tree70b10f78c9de6bc57bece430315bbb89b0820003
parentc61fc79be49b0bf5f5e9fdc1bc2818c8d8d639ea (diff)
downloadaur-9ae09c3b3a832adfcbc747ef9b948d8ae4a84cec.tar.gz
fixed deps. better pkgbuild
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 869dedbdcf9c..bccd091889d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,17 @@
pkgbase = git-it
- pkgdesc = Git-it is a desktop app that teaches you how to use Git and GitHub on the command line.
+ pkgdesc = Desktop app that teaches you how to use Git and GitHub on the command line.
pkgver = 4.3.3
- pkgrel = 5
+ pkgrel = 7
url = https://github.com/jlord/git-it-electron
arch = x86_64
license = BSD
+ depends = gnuplot
+ depends = libxtst
+ depends = libxss
+ depends = alsa-lib
+ depends = nodejs
+ depends = nss
+ depends = gconf
provides = git-it
source = https://github.com/jlord/git-it-electron/releases/download/4.3.3/Git-it-Linux-x64.zip
source = git-it.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 628910c1f37c..d20274787c09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,14 @@
pkgbase=git-it
pkgname=git-it
-pkgrel=5
+pkgrel=7
pkgver=4.3.3
-pkgdesc="Git-it is a desktop app that teaches you how to use Git and GitHub on the command line."
+pkgdesc="Desktop app that teaches you how to use Git and GitHub on the command line."
url="https://github.com/jlord/git-it-electron"
provides=('git-it')
arch=('x86_64')
license=('BSD')
-#depends=('electron' 'git' 'atom')
-depends=()
+depends=('gnuplot' 'libxtst' 'libxss' 'alsa-lib' 'nodejs' 'nss' 'gconf')
makedepends=()
backup=()
install=''
@@ -35,4 +34,5 @@ package() {
install -D -m644 "./${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -D -m644 "./${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -D -m644 "${srcdir}/Git-it-Linux-x64/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}