summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2018-06-28 19:10:20 -0400
committerChris Severance2018-06-28 19:10:20 -0400
commiteb134bb84834a0b319647805a2ecb5514b8e4014 (patch)
treea927ac6b0da6bcbe0070c3fb7366f99d4de3864d
parent9ae09c3b3a832adfcbc747ef9b948d8ae4a84cec (diff)
downloadaur-eb134bb84834a0b319647805a2ecb5514b8e4014.tar.gz
autu: Update to 4.3.3.0-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD59
2 files changed, 44 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bccd091889d2..aaa2c290d721 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu Jun 28 23:10:20 UTC 2018
pkgbase = git-it
pkgdesc = Desktop app that teaches you how to use Git and GitHub on the command line.
- pkgver = 4.3.3
- pkgrel = 7
+ pkgver = 4.3.3.0
+ pkgrel = 1
url = https://github.com/jlord/git-it-electron
arch = x86_64
license = BSD
@@ -13,12 +15,17 @@ pkgbase = git-it
depends = nss
depends = gconf
provides = git-it
- source = https://github.com/jlord/git-it-electron/releases/download/4.3.3/Git-it-Linux-x64.zip
+ noextract = Git-it-Linux-x64-4.3.0.zip
+ options = !strip
+ source = Git-it-Linux-x64-4.3.0.zip::https://github.com/jlord/git-it-electron/releases/download/4.3.0/Git-it-Linux-x64.zip
source = git-it.desktop
source = git-it.png
- md5sums = aa5ebe86a547afa9bcc7ae8c25b02109
+ md5sums = 2162a1c74af9baa4aa714780ae548504
md5sums = cc6162296991cdb4463081962c0018f1
md5sums = 3fc4074dd6efa11246481d57dae86cf1
+ sha256sums = 6a7308459fe0f6f7fc135e0cb76d6c6f2006851074d7ec7732e5760fa3e74d7c
+ sha256sums = 2ad08e42d2774e746c2730bcc90f089e2e97ad7c79875a52c3d341ad75affdfc
+ sha256sums = 55ff797c3449f24f5e53186f3e08aacd98b832b7191b8893c2d7b26b52e2a375
pkgname = git-it
diff --git a/PKGBUILD b/PKGBUILD
index d20274787c09..02fea556bb12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,45 @@
-# Maintainer: Aner Andros <code@anerandros.info>
+# Maintainer: Chris Severance aur.severach AatT spamgourmet.com
+# Contributor: Aner Andros <code@anerandros.info>
-pkgbase=git-it
-pkgname=git-it
-pkgrel=7
-pkgver=4.3.3
-pkgdesc="Desktop app that teaches you how to use Git and GitHub on the command line."
-url="https://github.com/jlord/git-it-electron"
-provides=('git-it')
+set -u
+pkgbase='git-it'
+pkgname='git-it'
+pkgver='4.3.3.0'; _pkgver='4.3.0'
+pkgrel='1'
+pkgdesc='Desktop app that teaches you how to use Git and GitHub on the command line.'
arch=('x86_64')
+url='https://github.com/jlord/git-it-electron'
license=('BSD')
depends=('gnuplot' 'libxtst' 'libxss' 'alsa-lib' 'nodejs' 'nss' 'gconf')
-makedepends=()
-backup=()
-install=''
-
+provides=('git-it')
+options=('!strip')
+_file="Git-it-Linux-x64-${_pkgver}.zip"
source=(
- "https://github.com/jlord/git-it-electron/releases/download/${pkgver}/Git-it-Linux-x64.zip"
- "${pkgname}.desktop"
- "${pkgname}.png"
+ "${_file}::https://github.com/jlord/git-it-electron/releases/download/${_pkgver}/Git-it-Linux-x64.zip"
+ "${pkgname}.desktop"
+ "${pkgname}.png"
)
-
-md5sums=('aa5ebe86a547afa9bcc7ae8c25b02109'
- 'cc6162296991cdb4463081962c0018f1'
- '3fc4074dd6efa11246481d57dae86cf1')
+noextract=("${_file}")
+md5sums=('2162a1c74af9baa4aa714780ae548504'
+ 'cc6162296991cdb4463081962c0018f1'
+ '3fc4074dd6efa11246481d57dae86cf1')
+sha256sums=('6a7308459fe0f6f7fc135e0cb76d6c6f2006851074d7ec7732e5760fa3e74d7c'
+ '2ad08e42d2774e746c2730bcc90f089e2e97ad7c79875a52c3d341ad75affdfc'
+ '55ff797c3449f24f5e53186f3e08aacd98b832b7191b8893c2d7b26b52e2a375')
package() {
- install -d "$pkgdir"/opt
+ set -u
+ install -d "${pkgdir}/opt/"
- cp -R "$srcdir"/Git-it-Linux-x64 "$pkgdir"/opt/git-it
+ bsdtar -C "${pkgdir}/opt/" -xf "${_file}"
+ mv "${pkgdir}/opt"/{Git-it-Linux-x64,git-it}
- install -d "$pkgdir"/usr/bin
- ln -sf ../../opt/git-it/Git-it "$pkgdir"/usr/bin/git-it
+ install -d "${pkgdir}/usr/bin"
+ ln -s '/opt/git-it/Git-it' "${pkgdir}/usr/bin/git-it"
- install -D -m644 "./${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -D -m644 "./${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- install -D -m644 "${srcdir}/Git-it-Linux-x64/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dpm644 "${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dpm644 "${pkgname}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dpm644 "${pkgdir}/opt/git-it/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ set +u
}
+set +u