summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlaï Deutel2019-05-17 01:02:45 -0700
committerIlaï Deutel2019-05-17 01:02:45 -0700
commit5dc3d8e7af0f8d9825080913c11fbe81bee94e3f (patch)
treedfc7c4c3e9c8b89e11526432e94f4391f69ac271
downloadaur-5dc3d8e7af0f8d9825080913c11fbe81bee94e3f.tar.gz
Initial commit - Version v2.9.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a8cc7c61ac4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = git-machete
+ pkgdesc = See what branches are out of sync with their parent branches and painlessly rebase them.
+ pkgver = 2.9.0
+ pkgrel = 1
+ url = https://github.com/VirtusLab/git-machete
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ makedepends = python2-pbr
+ depends = git
+ depends = python2
+ source = git-machete-2.9.0.tar.gz::https://github.com/VirtusLab/git-machete/archive/v2.9.0.tar.gz
+ sha256sums = faf680ff7e585d6759cfa0fe783cb874716ccf44b880423781dc356a1c3d8020
+
+pkgname = git-machete
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b498647db531
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Ilaï Deutel
+
+pkgname='git-machete'
+pkgver=2.9.0
+pkgrel=1
+pkgdesc='See what branches are out of sync with their parent branches and painlessly rebase them.'
+arch=('any')
+url='https://github.com/VirtusLab/git-machete'
+license=('MIT')
+depends=('git' 'python2')
+makedepends=('python2-setuptools' 'python2-pbr')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/VirtusLab/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('faf680ff7e585d6759cfa0fe783cb874716ccf44b880423781dc356a1c3d8020')
+
+prepare() {
+ export PBR_VERSION="$pkgver"
+}
+
+build() {
+ cd "$srcdir/$pkgname-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-${pkgver}"
+
+ # Install the package
+ python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+
+ # Install bash and zsh completions
+ install -Dm644 "completion/git-machete.completion.bash" "$pkgdir/usr/share/bash-completion/completions/git-machete"
+ install -Dm644 "completion/git-machete.completion.zsh" "$pkgdir/usr/share/zsh/site-functions/_git-machete"
+
+ # Install the license
+ install -Dm 644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}