summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlaï Deutel2023-09-03 17:18:45 -0400
committerIlaï Deutel2023-09-03 17:19:23 -0400
commitb5219f160490d90fc7643c1f2d2a845b4d4ab628 (patch)
tree9e6c4e0f51fbfbd713eacdc43dc0fa774adb752c
parent2b13cdcc6484748eb68a0f81e889fcaf2b156194 (diff)
downloadaur-b5219f160490d90fc7643c1f2d2a845b4d4ab628.tar.gz
upgpkg: git-machete 3.18.1-1
upstream release
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 30 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1f1a4cb46ae..391ddf58ea97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,21 @@
pkgbase = git-machete
pkgdesc = Probably the sharpest git repository organizer & rebase/merge workflow automation tool you've ever seen
- pkgver = 3.17.8
+ pkgver = 3.18.1
pkgrel = 1
url = https://github.com/VirtusLab/git-machete
arch = any
license = MIT
checkdepends = python-pytest
checkdepends = python-pytest-mock
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = git
depends = python
- source = git-machete-3.17.8.tar.gz::https://github.com/VirtusLab/git-machete/archive/v3.17.8.tar.gz
- sha256sums = d9840bb5e7e46f699217d27af79a670bbd12a79155afc99696ddb5d2d87d0973
+ optdepends = bash: bash completion
+ optdepends = fish: fish completion
+ optdepends = zsh: zsh completion
+ source = git-machete-3.18.1.tar.gz::https://github.com/VirtusLab/git-machete/archive/v3.18.1.tar.gz
+ sha256sums = a9ec611b654fd8b9b257cb32a4d6e3bd7a132375af77827608646d9463ee9df7
pkgname = git-machete
diff --git a/PKGBUILD b/PKGBUILD
index f4daec2ad779..8b4cea0fafea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,51 @@
# Maintainer: Ilaï Deutel <PlMWPh1WSmypRv0JQljz> (echo ... | tr 'A-Za-z' 'l-za-kL-ZA-K' | base64 -d)
pkgname='git-machete'
-pkgver=3.17.8
+pkgver=3.18.1
pkgrel=1
pkgdesc="Probably the sharpest git repository organizer & rebase/merge workflow automation tool you've ever seen"
arch=('any')
url='https://github.com/VirtusLab/git-machete'
license=('MIT')
depends=('git' 'python')
-makedepends=('python-setuptools')
+makedepends=(python-build python-installer python-wheel)
+optdepends=('bash: bash completion'
+ 'fish: fish completion'
+ 'zsh: zsh completion')
checkdepends=('python-pytest' 'python-pytest-mock')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/VirtusLab/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('d9840bb5e7e46f699217d27af79a670bbd12a79155afc99696ddb5d2d87d0973')
+sha256sums=('a9ec611b654fd8b9b257cb32a4d6e3bd7a132375af77827608646d9463ee9df7')
+
+prepare() {
+ cd "$srcdir/$pkgname-${pkgver}"
+ # Only install git_machete as a Python package
+ sed -i "s/packages=.*,$/packages=['git_machete'],/" setup.py
+}
build() {
cd "$srcdir/$pkgname-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
cd "$srcdir/$pkgname-${pkgver}"
- GITHUB_TOKEN='' pytest
+ GITHUB_TOKEN='' pytest -m 'not completion_e2e'
}
package() {
cd "$srcdir/$pkgname-${pkgver}"
# Install the package
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
- # Install bash and zsh completions
+ # Install bash, zsh and fish completions
install -Dm644 "completion/git-machete.completion.bash" "$pkgdir/usr/share/bash-completion/completions/git-machete"
install -Dm644 "completion/git-machete.completion.zsh" "$pkgdir/usr/share/zsh/site-functions/_git-machete"
+ install -Dm644 "completion/git-machete.fish" "$pkgdir//usr/share/fish/vendor_completions.d/git-machete.fish"
- # Install the license
+ # Add the license
install -Dm 644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # Add the man page
+ install -Dm 644 "docs/man/git-machete.1" "$pkgdir/usr/share/man/man1/git-machete.1"
}