summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2019-08-14 20:28:25 +0200
committerKr1ss2019-08-14 20:30:13 +0200
commitfae3eae96af1727e1eabe18903653648d7a2e7a9 (patch)
tree6a0d39dd99221c020e785100f7a25bb0f6213d8c
parent9d370c8a342924b4366f2a8349f8570a21e7110b (diff)
downloadaur-fae3eae96af1727e1eabe18903653648d7a2e7a9.tar.gz
add changelog, zsh plugin and manpage
-rw-r--r--.SRCINFO5
-rw-r--r--CHANGELOG24
-rw-r--r--PKGBUILD18
3 files changed, 43 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a6289c20723..dbe0df761527 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = git-open-git
pkgdesc = Type `git open` to open the GitHub page or website for a repository in your browser.
pkgver = 2.1.0.r8.g08fa2ab
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/paulirish/git-open
+ changelog = CHANGELOG
arch = x86_64
license = MIT
+ makedepends = go-md2man
depends = git
depends = xdg-utils
provides = git-open
conflicts = nodejs-git-open
conflicts = git-open
+ options = zipman
source = git+https://github.com/paulirish/git-open.git
sha256sums = SKIP
diff --git a/CHANGELOG b/CHANGELOG
new file mode 100644
index 000000000000..1de00cda2321
--- /dev/null
+++ b/CHANGELOG
@@ -0,0 +1,24 @@
+Version 2.1.0 (2018-12-3) https://github.com/:paulirish/git-open/releases/tag/v2.1.0
+
+Full changelog https://github.com/:paulirish/git-open/compare/v2.0.0...v2.1.0
+
+
+New features :
+
+- Support opening current tag / commit
+- Add man page
+- Add support for sshconfig expansion
+- Add support for Bitbucket Server with different root context
+- Add support for AWS Code commit
+
+
+Bug fixes :
+
+- Fix bug with open -i on default VSTS project repo
+- Use ls-remote --get-url to get remote url
+- Fix shellcheck
+- Fix incompatability with bash < 4
+- Swap uppercase/lowercase for ssh feature
+- Remove openopt, allow spaces in $BROWSER
+- readme: One liner install for oh-my-zsh
+- deps: change markdownlint to markdownlint-cli
diff --git a/PKGBUILD b/PKGBUILD
index 537b9c6f9e81..bce84e2fc1df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgver() {
git describe | sed 's/v\?//;s/-/.r/;s/-/./'
}
pkgver=2.1.0.r8.g08fa2ab
-pkgrel=1
+pkgrel=2
pkgdesc='Type `git open` to open the GitHub page or website for a repository in your browser.'
arch=('x86_64')
@@ -20,14 +20,26 @@ provides=("${pkgname%-git}")
conflicts=('nodejs-git-open' "${pkgname%-git}")
depends=('git' 'xdg-utils')
+makedepends=('go-md2man')
+options=('zipman')
+
+changelog=CHANGELOG
source=("git+$url.git")
sha256sums=('SKIP')
-package() {
+prepare() {
cd "${pkgname%-git}"
+ go-md2man <"${pkgname%-git}.1.md" >"${pkgname%-git}.1"
+}
+package() {
+ cd "${pkgname%-git}"
install -Dm755 "${pkgname%-git}" -t"$pkgdir/usr/bin/"
- install -Dm644 "${pkgname%-git}.1.md" "$pkgdir/usr/share/doc/${pkgname%-git}/README.md"
+ install -Dm644 "${pkgname%-git}.plugin.zsh" -t"$pkgdir/usr/share/${pkgname%-git}/"
+ install -Dm644 "${pkgname%-git}.1" -t"$pkgdir/usr/share/man/man1/"
+ install -Dm644 "${pkgname%-git}.1.md" README.md -t"$pkgdir/usr/share/doc/${pkgname%-git}/"
install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE.md"
}
+
+# vim: ts=2 sw=2 et: