summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2016-10-28 16:35:42 +0100
committerEmmanuel Gil Peyrot2016-10-28 16:35:42 +0100
commit17fe696337367984a811236979f503a6f8c2792f (patch)
treed95ea5f933b110277387ca900f42debd00b77d4f
parent2cedd8d92cd3407562683e1448059cbeb24e4158 (diff)
downloadaur-17fe696337367984a811236979f503a6f8c2792f.tar.gz
Also generate and install the manpage.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c87b80118b8d..a255b01ae4f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Oct 28 15:30:48 UTC 2016
+# Fri Oct 28 15:35:30 UTC 2016
pkgbase = git-phab-git
pkgdesc = Git subcommand to integrate with phabricator
pkgver = r163.b59c888
@@ -8,6 +8,7 @@ pkgbase = git-phab-git
arch = any
license = GPL2
makedepends = git
+ makedepends = asciidoc
depends = python-git
depends = python-phabricator
depends = python-argcomplete
diff --git a/PKGBUILD b/PKGBUILD
index c74daed736fe..ba538e66a83d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ license=('GPL2')
depends=('python-git' 'python-phabricator' 'python-argcomplete' 'python-appdirs')
provides=("$_pkgname")
conflicts=("$_pkgname")
-makedepends=('git')
+makedepends=('git' 'asciidoc')
source=("$_pkgname::git://anongit.freedesktop.org/git/$_pkgname")
md5sums=('SKIP')
@@ -20,9 +20,14 @@ pkgver() {
echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
+build() {
+ cd "$srcdir/$_pkgname"
+ a2x --doctype manpage --format manpage git-phab.txt
+}
+
package() {
cd "$srcdir/$_pkgname"
install -Dm755 git-phab "$pkgdir/usr/bin/$_pkgname"
- install -Dm644 git-phab.txt "$pkgdir/usr/share/doc/$_pkgname/$_pkgname.txt"
+ install -Dm644 git-phab.1 "$pkgdir/usr/share/man/man1/$_pkgname.1"
install -Dm644 README.md "$pkgdir/usr/share/doc/$_pkgname/README"
}