summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikhail f. Shiryaev2019-04-13 16:16:15 +0200
committerMikhail f. Shiryaev2019-04-13 16:16:15 +0200
commit407161d2c903962402b6e9b9f821244a0bb668b1 (patch)
treecc56b803cecc90892ce8307dba93f109b44db3cc
downloadaur-407161d2c903962402b6e9b9f821244a0bb668b1.tar.gz
Release git-prompt.zsh
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f19117f7566
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = git-prompt.zsh
+ pkgdesc = A fast, pure-shell, single-file Git prompt for Zsh.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/woefe/git-prompt.zsh
+ arch = any
+ license = MIT
+ depends = git
+ source = https://github.com/woefe/git-prompt.zsh/archive/v1.0.0.tar.gz
+ sha1sums = 46afe36ac8636b779e31cdcd9ed4f61eca06a58d
+
+pkgname = git-prompt.zsh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b52dcaa72e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Mikhail felixoid Shiryaev mr<dot>felixoid<at>gmail<dot>com
+
+_name='git-prompt.zsh'
+pkgname="${_name}"
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='A fast, pure-shell, single-file Git prompt for Zsh.'
+arch=('any')
+url="https://github.com/woefe/${_name}"
+license=('MIT')
+source=("https://github.com/woefe/git-prompt.zsh/archive/v${pkgver}.tar.gz")
+depends=('git')
+sha1sums=('46afe36ac8636b779e31cdcd9ed4f61eca06a58d')
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ install -d ${pkgdir}/usr/share/zsh/scripts
+ install -m 0644 "${_name}" ${pkgdir}/usr/share/zsh/scripts/
+}