summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2018-11-16 09:52:10 +0000
committerEric Engestrom2018-11-16 09:52:10 +0000
commitafdd96c28256fb453df0a6e467834f518dfb0d17 (patch)
treea11396c25df07f75384a4f8057c076a00ba35384
downloadaur-afdd96c28256fb453df0a6e467834f518dfb0d17.tar.gz
initial commit - v1.5.0.1+
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD30
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aae158e50879
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = git-pw-git
+ pkgdesc = Git integration for Patchwork, the web-based patch tracking system
+ pkgver = 1.5.0.1+ged39855379
+ pkgrel = 1
+ url = https://github.com/getpatchwork/git-pw
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pbr
+ depends = python-click
+ depends = python-requests
+ depends = python-tabulate
+ depends = python-arrow
+ provides = git-pw=1.5.0.1
+ conflicts = git-pw
+ source = https://github.com/getpatchwork/git-pw
+ sha256sums = SKIP
+
+pkgname = git-pw-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1881ad4be3f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=git-pw-git
+pkgver=1.5.0.1+ged39855379
+pkgrel=1
+pkgdesc="Git integration for Patchwork, the web-based patch tracking system"
+arch=(any)
+url="https://github.com/getpatchwork/git-pw"
+license=(MIT)
+source=("git+$url")
+sha256sums=(SKIP)
+depends=(python python-{pbr,click,requests,tabulate,arrow})
+makedepends=(python-setuptools)
+conflicts=(git-pw)
+provides=("git-pw=${pkgver%+*}")
+
+pkgver() {
+ cd git-pw
+ git describe --long --abbrev=10 | sed 's/-/./; s/-/+/; s/-/./'
+}
+
+build() {
+ cd git-pw
+ python setup.py build
+}
+
+package() {
+ cd git-pw
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}