summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime “pep” Buquet2019-04-24 15:11:18 +0100
committerMaxime “pep” Buquet2019-04-24 15:11:18 +0100
commite2e48c58117c548a85e0aa8b8c30a14a312294f7 (patch)
tree2d0991850bcbf8a27cc885e819ffb577212cf01f
parentafdd96c28256fb453df0a6e467834f518dfb0d17 (diff)
downloadaur-e2e48c58117c548a85e0aa8b8c30a14a312294f7.tar.gz
Initial commit
Signed-off-by: Maxime “pep” Buquet <pep@bouah.net>
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD45
2 files changed, 29 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aae158e50879..9fdc345b6de0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
pkgbase = git-pw-git
- pkgdesc = Git integration for Patchwork, the web-based patch tracking system
- pkgver = 1.5.0.1+ged39855379
+ pkgdesc = A tool for integrating Git with Patchwork, the web-based patch tracking system
+ pkgver = 1.5.1.r2.g0e4a1fd
pkgrel = 1
url = https://github.com/getpatchwork/git-pw
arch = any
license = MIT
makedepends = python-setuptools
- depends = python
- depends = python-pbr
- depends = python-click
depends = python-requests
- depends = python-tabulate
+ depends = python-click
+ depends = python-pbr
depends = python-arrow
- provides = git-pw=1.5.0.1
- conflicts = git-pw
- source = https://github.com/getpatchwork/git-pw
+ depends = python-tabulate
+ source = git-pw::git+https://github.com/getpatchwork/git-pw.git
sha256sums = SKIP
pkgname = git-pw-git
diff --git a/PKGBUILD b/PKGBUILD
index 1881ad4be3f6..62e535a8593f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,31 @@
-# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+# Maintainer: Maxime "pep" Buquet <archlinux@bouah.net>
-pkgname=git-pw-git
-pkgver=1.5.0.1+ged39855379
+_pkgname=git-pw
+pkgname=${_pkgname}-git
+pkgver=1.5.1.r2.g0e4a1fd
pkgrel=1
-pkgdesc="Git integration for Patchwork, the web-based patch tracking system"
-arch=(any)
-url="https://github.com/getpatchwork/git-pw"
-license=(MIT)
-source=("git+$url")
-sha256sums=(SKIP)
-depends=(python python-{pbr,click,requests,tabulate,arrow})
-makedepends=(python-setuptools)
-conflicts=(git-pw)
-provides=("git-pw=${pkgver%+*}")
+pkgdesc="A tool for integrating Git with Patchwork, the web-based patch tracking system"
+url='https://github.com/getpatchwork/git-pw'
+license=('MIT')
+arch=('any')
+depends=(
+ 'python-requests'
+ 'python-click'
+ 'python-pbr'
+ 'python-arrow'
+ 'python-tabulate'
+)
+makedepends=('python-setuptools')
+source=("${_pkgname}::git+https://github.com/getpatchwork/git-pw.git")
+sha256sums=('SKIP')
pkgver() {
- cd git-pw
- git describe --long --abbrev=10 | sed 's/-/./; s/-/+/; s/-/./'
-}
-
-build() {
- cd git-pw
- python setup.py build
+ cd ${_pkgname}
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd git-pw
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd ${_pkgname}
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}