summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorriderius2023-10-17 11:01:24 +0300
committerriderius2024-02-16 13:26:46 +0300
commit18eb3949b8b17a710585b47e02accf7093c54926 (patch)
tree0a169b3798fa821c07740b70a239445f1a212fea
parent503675609f266cb4718f498f42e9e0c8f11a5996 (diff)
downloadaur-18eb3949b8b17a710585b47e02accf7093c54926.tar.gz
Update to v2.5.2
Also add a patch to fix timezones Signed-off-by: riderius <riderius.help@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4eabbd4994f..3b3ebe79b04b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = git-quick-stats
- pkgdesc = `git-quick-stats` is a simple and efficient way to access various statistics in git repository.
- pkgver = 2.4.1
+ pkgdesc = Simple and efficient way to access various statistics in git repository
+ pkgver = 2.5.2
pkgrel = 1
url = https://github.com/arzzen/git-quick-stats
- arch = x86_64
+ arch = any
license = MIT
depends = bash
depends = coreutils
@@ -14,7 +14,9 @@ pkgbase = git-quick-stats
depends = util-linux
provides = git-quick-stats
conflicts = git-quick-stats
- source = git-quick-stats::git+https://github.com/arzzen/git-quick-stats#tag=2.4.1
+ source = git-quick-stats::git+https://github.com/arzzen/git-quick-stats#tag=2.5.2
+ source = git-quick-stats-timezone-fix-1.patch::https://patch-diff.githubusercontent.com/raw/arzzen/git-quick-stats/pull/142.patch
sha256sums = SKIP
+ sha256sums = 59190da26955b010db03e293be4724629a10b9e8efa447b3f647128c8b3fc56d
pkgname = git-quick-stats
diff --git a/PKGBUILD b/PKGBUILD
index 7b5313ec9ad9..e10f649b7441 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: Kevin Kuehler <keur@xcf.berkeley.edu>
+# Maintainer: Riderius <riderius.help@gmail.com>
+# Previous maintainer: Kevin Kuehler <keur@xcf.berkeley.edu>
pkgname='git-quick-stats'
-pkgver='2.4.1'
+pkgver='2.5.2'
pkgrel=1
-pkgdesc='`git-quick-stats` is a simple and efficient way to access various statistics in git repository.'
-arch=('x86_64')
+pkgdesc='Simple and efficient way to access various statistics in git repository'
+arch=('any')
url="https://github.com/arzzen/$pkgname"
license=('MIT')
depends=(
@@ -19,8 +20,15 @@ depends=(
makedepends=()
provides=('git-quick-stats')
conflicts=('git-quick-stats')
-source=("$pkgname::git+$url#tag=$pkgver")
-sha256sums=('SKIP')
+source=("$pkgname::git+$url#tag=$pkgver"
+ "$pkgname-timezone-fix-1.patch::https://patch-diff.githubusercontent.com/raw/arzzen/git-quick-stats/pull/142.patch")
+sha256sums=('SKIP'
+ '59190da26955b010db03e293be4724629a10b9e8efa447b3f647128c8b3fc56d')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ git apply "${srcdir}"/142.patch
+}
check() {
cd "$srcdir/$pkgname"