summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Kuehler2019-08-11 13:43:58 -0700
committerKevin Kuehler2019-08-11 13:45:03 -0700
commit562eaad296fcb08352f73ac916e046f71baf26f0 (patch)
tree9f3e97f790cbabdfec1f6bdc321ab83e8f1f467d
downloadaur-562eaad296fcb08352f73ac916e046f71baf26f0.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ffebd387f10f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = git-quick-stats
+ pkgdesc = `git-quick-stats` is a simple and efficient way to access various statistics in git repository.
+ pkgver = 2.0.8
+ pkgrel = 1
+ url = https://github.com/arzzen/git-quick-stats
+ arch = x86_64
+ license = MIT
+ depends = git
+ provides = git-quick-stats
+ conflicts = git-quick-stats
+ source = git-quick-stats::git+https://github.com/arzzen/git-quick-stats#tag=2.0.8
+ sha256sums = SKIP
+
+pkgname = git-quick-stats
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc5e009e75c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainr: Kevin Kuehler <keur@ocf.berkeley.edu>
+
+pkgname='git-quick-stats'
+pkgver='2.0.8'
+pkgrel=1
+pkgdesc='`git-quick-stats` is a simple and efficient way to access various statistics in git repository.'
+arch=('x86_64')
+url="https://github.com/arzzen/$pkgname"
+license=('MIT')
+depends=('git')
+makedepends=()
+provides=('git-quick-stats')
+conflicts=('git-quick-stats')
+source=("$pkgname::git+$url#tag=$pkgver")
+sha256sums=('SKIP')
+
+check() {
+ cd "$srcdir/$pkgname"
+ make test
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make PREFIX="$pkgdir/usr" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}