summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTristan Druyen2023-09-06 15:02:55 +0200
committerTristan Druyen2023-09-06 15:06:17 +0200
commit5238d47bfdb0384f58f615793ec0cf3ecadb94d1 (patch)
tree4fdbe586819f70438039f5596a714635bcbcc352
downloadaur-5238d47bfdb0384f58f615793ec0cf3ecadb94d1.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9296a8d4a9e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = git-repo-bin
+ pkgdesc = CLI for agit flow
+ pkgver = 0.7.8
+ pkgrel = 1
+ url = https://github.com/alibaba/git-repo-go
+ arch = x86_64
+ license = Apache
+ depends = pacman>5
+ depends = git
+ provides = git-repo
+ conflicts = git-repo
+ source_x86_64 = https://github.com/alibaba/git-repo-go/releases/download/v0.7.8/git-repo-0.7.8-Linux-64.tar.gz
+ sha256sums_x86_64 = 92fe06087dea70d34e4cf62786b2bf58f51a47407a89775825a006b80acf0dc3
+
+pkgname = git-repo-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9de8a497ffd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Vault81 <aur at vault81.de>
+pkgname=git-repo-bin
+pkgver=0.7.8
+pkgrel=1
+pkgdesc="CLI for agit flow"
+arch=('x86_64')
+url="https://github.com/alibaba/git-repo-go"
+license=('Apache')
+depends=(
+ 'pacman>5'
+ 'git'
+)
+provides=('git-repo')
+conflicts=('git-repo')
+
+source_x86_64=("https://github.com/alibaba/git-repo-go/releases/download/v${pkgver}/${pkgname/-bin/}-${pkgver}-Linux-64.tar.gz")
+sha256sums_x86_64=('92fe06087dea70d34e4cf62786b2bf58f51a47407a89775825a006b80acf0dc3')
+
+package() {
+ _output="${srcdir}/${pkgname/-bin/}-${pkgver}-Linux-64"
+ install -Dm755 "${_output}/${pkgname/-bin/}" "${pkgdir}/usr/bin/${pkgname/-bin/}"
+}
+