summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2018-09-25 19:05:36 -0700
committerBenjamin Denhartog2018-09-25 19:05:36 -0700
commitc8cc4127c2bc6c234e918fb25a3004a15e0b51fc (patch)
tree159fa95b3e53f0550793f92e5b0238de38467f51
downloadaur-c8cc4127c2bc6c234e918fb25a3004a15e0b51fc.tar.gz
initial upload: git-shelf 1.0.0-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0acd1613e08a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = git-shelf
+ pkgdesc = Store work-in-progress commits on the remote without cluttering the commit history
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/sudoforge/git-shelf
+ arch = any
+ license = MIT
+ depends = git
+ source = git-shelf-1.0.0.tar.gz::https://github.com/sudoforge/git-shelf/archive/1.0.0.tar.gz
+ sha256sums = 398fb7b50179d30ea1e7913fb696d7aa2edbbfd05ecb8182006eb661afaa2270
+
+pkgname = git-shelf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7b1ed8f7b25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Benjamin Denhartog <ben@sudoforge.com>
+
+# This PKGBUILD is managed at https://github.com/sudoforge/pkgbuilds
+
+pkgname=git-shelf
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Store work-in-progress commits on the remote without cluttering the commit history"
+arch=('any')
+url="https://github.com/sudoforge/${pkgname}"
+license=('MIT')
+depends=('git')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('398fb7b50179d30ea1e7913fb696d7aa2edbbfd05ecb8182006eb661afaa2270')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}