summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAbdo Roig-Maranges2017-09-20 10:25:10 +0200
committerAbdo Roig-Maranges2017-09-20 10:25:10 +0200
commit0d56f732995425832d03621aa00b094cfc933a20 (patch)
tree9b594710027c6daf1718ecf4c2b6e79275285c3e
parent7b0d9bb5b7f739bda4efad452df3bf6443936507 (diff)
downloadaur-0d56f732995425832d03621aa00b094cfc933a20.tar.gz
pin on version 3.3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9ec4ad43749..c86268223591 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = git-spindle-git
+pkgbase = git-spindle
pkgdesc = Git subcommands for integrating with central services like github, gitlab and bitbucket
- pkgver = 3.3.r16.g6a6c920
+ pkgver = 3.3
pkgrel = 1
url = http://github.com/seveas/git-spindle
arch = any
@@ -12,10 +12,8 @@ pkgbase = git-spindle-git
depends = python-github3
depends = python-whelk
depends = python-docopt
- provides = git-spindle
- conflicts = git-spindle
- source = git+https://github.com/seveas/git-spindle.git
- md5sums = SKIP
+ source = https://github.com/seveas/git-spindle/archive/3.3.tar.gz
+ sha256sums = 4bfad8e716e16e267c1297bb66b563a5eb4a3f90d618338442529a9c773bd4d1
-pkgname = git-spindle-git
+pkgname = git-spindle
diff --git a/PKGBUILD b/PKGBUILD
index 299a8ceea0c9..b5433dfb591e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Abdó Roig-Maranges <abdo.roig@gmail.com>
-pkgname=git-spindle-git
-pkgver=3.3.r16.g6a6c920
+pkgname=git-spindle
+pkgver=3.3
pkgrel=1
pkgdesc="Git subcommands for integrating with central services like github, gitlab and bitbucket"
arch=('any')
@@ -10,17 +10,11 @@ license=('GPL3')
depends=('git' 'python' 'python-github3' 'python-whelk' 'python-docopt')
makedepends=('make' 'python-sphinx')
optdepends=()
-provides=('git-spindle')
-conflicts=('git-spindle')
-source=("git+https://github.com/seveas/git-spindle.git")
-md5sums=('SKIP')
-
-pkgver() {
- git --git-dir="$srcdir/git-spindle/.git" describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
+source=("https://github.com/seveas/git-spindle/archive/${pkgver}.tar.gz")
+sha256sums=('4bfad8e716e16e267c1297bb66b563a5eb4a3f90d618338442529a9c773bd4d1')
prepare() {
- cd "${srcdir}/git-spindle"
+ cd "${srcdir}/git-spindle-${pkgver}"
# NOTE: Since we only build the man page, we tweak docs configuration so that
# it does not require a sphinx theme.
@@ -28,14 +22,14 @@ prepare() {
}
build() {
- cd "$srcdir/git-spindle"
+ cd "$srcdir/git-spindle-${pkgver}"
python setup.py build
LANG=en_US.UTF-8 make -C docs man
}
package() {
- cd "$srcdir/git-spindle"
+ cd "$srcdir/git-spindle-${pkgver}"
python setup.py install --prefix=/usr --root="$pkgdir"
install -d "$pkgdir/usr/share/man/man1/"