diff options
author | pyamsoft | 2018-03-06 19:42:45 -0800 |
---|---|---|
committer | pyamsoft | 2018-03-06 19:42:45 -0800 |
commit | 3442b3c10984b260706f472b30f99a69431d55ad (patch) | |
tree | 96dac15b35e19ee0c58a8137bb9a4d70badf75e4 | |
parent | 29117944fa46b400d0fbe34d5910cd90f01ae2fd (diff) | |
download | aur-3442b3c10984b260706f472b30f99a69431d55ad.tar.gz |
Rewrite the script in python
-rw-r--r-- | .SRCINFO | 5 | ||||
-rw-r--r-- | PKGBUILD | 6 |
2 files changed, 7 insertions, 4 deletions
@@ -1,6 +1,6 @@ pkgbase = git-ssh-git pkgdesc = A wrapper around git to work with multiple SSH keys - pkgver = r161.09f422c + pkgver = r181.0ffd8e6 pkgrel = 1 url = https://github.com/pyamsoft/git-ssh.git install = git-ssh.install @@ -8,6 +8,9 @@ pkgbase = git-ssh-git license = GPLv2 makedepends = git depends = git + depends = python + depends = python-setuptools + depends = python-sh provides = git-ssh conflicts = git-ssh source = git-ssh::git+https://github.com/pyamsoft/git-ssh.git#branch=master @@ -8,7 +8,7 @@ pkgname=git-ssh-git # shellcheck disable=SC2034 pkgdesc="A wrapper around git to work with multiple SSH keys" # shellcheck disable=SC2034 -pkgver=r161.09f422c +pkgver=r181.0ffd8e6 # shellcheck disable=SC2034 pkgrel=1 # shellcheck disable=SC2034 @@ -16,7 +16,7 @@ arch=('any') # shellcheck disable=SC2034 makedepends=('git') # shellcheck disable=SC2034 -depends=('git') +depends=('git' 'python' 'python-setuptools' 'python-sh') # shellcheck disable=SC2034 optdepends=() # shellcheck disable=SC2034 @@ -61,7 +61,7 @@ package() { } # shellcheck disable=SC2154 - install -Dm 755 "${_gitname}" "${pkgdir}/usr/bin/${_gitname}" + python setup.py install --root="${pkgdir}" --optimize=1 install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${_gitname}/LICENSE" } |