summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormike-work2017-03-22 11:19:02 +0000
committermike-work2017-03-22 11:19:02 +0000
commit161511b31dbb5b5c8608755b9afd8a3dd7698770 (patch)
treea475d4ccc242c17772bb07e36f75ebba3ba23a74
downloadaur-161511b31dbb5b5c8608755b9afd8a3dd7698770.tar.gz
Package git-standup
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48c917206367
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = git-standup-git
+ pkgdesc = Recall what you did on the last working day.
+ pkgver = r99.5ae7d15
+ pkgrel = 1
+ url = https://github.com/kamranahmedse/git-standup
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = make
+ depends = bash
+ provides = git-standup
+ conflicts = git-standup
+ source = git-standup::git+https://github.com/kamranahmedse/git-standup
+ md5sums = SKIP
+
+pkgname = git-standup-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a38e7988ae7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Michael Hauser-Raspe
+pkgname=git-standup-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=r99.5ae7d15
+pkgrel=1
+pkgdesc="Recall what you did on the last working day."
+arch=('any')
+url="https://github.com/kamranahmedse/git-standup"
+license=('MIT')
+depends=('bash')
+makedepends=('git' 'make') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git-standup::git+https://github.com/kamranahmedse/git-standup')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ sudo make install
+} \ No newline at end of file