diff options
author | a821 | 2024-02-20 11:07:54 +0100 |
---|---|---|
committer | a821 | 2024-02-20 11:07:54 +0100 |
commit | 2690803871f849d711c5af81e21d275360f19e67 (patch) | |
tree | d48b0f380d4584226bc5ced686b71e41b48954ee | |
parent | 161511b31dbb5b5c8608755b9afd8a3dd7698770 (diff) | |
download | aur-2690803871f849d711c5af81e21d275360f19e67.tar.gz |
fix PKGBUILD
-rw-r--r-- | .SRCINFO | 8 | ||||
-rw-r--r-- | PKGBUILD | 31 |
2 files changed, 15 insertions, 24 deletions
@@ -1,17 +1,15 @@ pkgbase = git-standup-git pkgdesc = Recall what you did on the last working day. - pkgver = r99.5ae7d15 + pkgver = 2.3.2.r8.g77051be pkgrel = 1 url = https://github.com/kamranahmedse/git-standup arch = any license = MIT - makedepends = git - makedepends = make depends = bash + depends = git provides = git-standup conflicts = git-standup - source = git-standup::git+https://github.com/kamranahmedse/git-standup + source = git+https://github.com/kamranahmedse/git-standup md5sums = SKIP pkgname = git-standup-git - @@ -1,33 +1,26 @@ -# This is an example PKGBUILD file. Use this as a start to creating your own, -# and remove these comments. For more information, see 'man PKGBUILD'. -# NOTE: Please fill out the license field for your package! If it is unknown, -# then please put 'unknown'. +# Maintainer: +# Contributor: Michael Hauser-Raspe -# The following guidelines are specific to BZR, GIT, HG and SVN packages. -# Other VCS sources are not natively supported by makepkg yet. - -# Maintainer: Michael Hauser-Raspe -pkgname=git-standup-git # '-bzr', '-git', '-hg' or '-svn' -pkgver=r99.5ae7d15 +pkgname=git-standup-git +pkgver=2.3.2.r8.g77051be pkgrel=1 pkgdesc="Recall what you did on the last working day." arch=('any') url="https://github.com/kamranahmedse/git-standup" license=('MIT') -depends=('bash') -makedepends=('git' 'make') # 'bzr', 'git', 'mercurial' or 'subversion' +depends=('bash' 'git') provides=("${pkgname%-git}") conflicts=("${pkgname%-git}") -source=('git-standup::git+https://github.com/kamranahmedse/git-standup') +source=("git+$url") md5sums=('SKIP') pkgver() { - cd "$srcdir/${pkgname%-git}" -# Git, no tags available - printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" + cd "${pkgname%-git}" + git describe --tags | sed 's/-/.r/;s/-/./g' } package() { - cd "$srcdir/${pkgname%-git}" - sudo make install -}
\ No newline at end of file + cd "${pkgname%-git}" + install -Dm755 -t "$pkgdir/usr/bin" git-standup + install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE +} |