summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Gravier2017-05-31 09:22:15 -0400
committerKevin Gravier2017-05-31 09:22:15 -0400
commit582ae5e9e33eabc5bbadccdc73bab5e65661e76a (patch)
tree7be0e1c4df364d013c3741a8bff4b08890ef774d
downloadaur-582ae5e9e33eabc5bbadccdc73bab5e65661e76a.tar.gz
v0.6.0
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD40
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07527fefcb9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = git-stream-git
+ pkgdesc = A git flow replacement with a single branch model
+ pkgver = 0.6.0.r1.g83e41f0
+ pkgrel = 1
+ url = https://github.com/mrkmg/git-stream
+ arch = any
+ license = MIT
+ depends = git
+ provides = git-stream
+ source = git-stream::git+https://github.com/mrkmg/git-stream.git
+ md5sums = SKIP
+
+pkgname = git-stream-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a6aa625a1dec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+# Created by .ignore support plugin (hsz.mobi)
+### ArchLinuxPackages template
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+git-stream/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80f92c87744e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Kevin Gravier
+pkgname=git-stream-git
+pkgver=0.6.0.r1.g83e41f0
+pkgrel=1
+pkgdesc="A git flow replacement with a single branch model"
+arch=(any)
+url="https://github.com/mrkmg/git-stream"
+license=('MIT')
+groups=()
+depends=('git')
+makedepends=()
+provides=(git-stream)
+
+source=(git-stream::git+https://github.com/mrkmg/git-stream.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd git-stream
+ git submodule update --init --recursive
+}
+
+build() {
+ cd git-stream
+ make test
+}
+
+package() {
+ cd git-stream
+ PREFIX=$pkgdir/usr make install
+}
+
+pkgver() {
+ cd git-stream
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}