summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Rodas2015-06-25 00:33:10 -0500
committerMario Rodas2015-06-25 00:33:10 -0500
commit6be3e1e5e93ff3b83f384cee397e614036d778ed (patch)
tree156df4e32eef0f6822c5de21b08ea6ce375c3615
downloadaur-git-test-git.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c2a56772854
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = git-test-git
+ pkgdesc = Git extension to conveniently test all distinct versions.
+ pkgver = r7.e71d22f
+ pkgrel = 1
+ url = https://github.com/spotify/git-test
+ arch = any
+ license = Apache
+ depends = git
+ source = git-test::git+https://github.com/spotify/git-test.git
+ md5sums = SKIP
+
+pkgname = git-test-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c432d87cb65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Mario Rodas <marsam@users.noreply.github.com>
+
+pkgname=git-test-git
+_gitname=git-test
+pkgver=r7.e71d22f
+pkgrel=1
+pkgdesc="Git extension to conveniently test all distinct versions."
+arch=('any')
+license=('Apache')
+url="https://github.com/spotify/git-test"
+depends=('git')
+source=("$_gitname::git+https://github.com/spotify/git-test.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ install -Dm 0755 git-test "$pkgdir/usr/bin/git-test"
+ install -Dm 0644 git-test.1 "$pkgdir/usr/share/man/man1/git-test.1"
+}