summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Schumacher2019-09-19 15:13:35 +0200
committerTim Schumacher2019-09-19 15:13:35 +0200
commita00f2a21de3f401cfea2332b5691b4ea4bde8511 (patch)
treef58b00fc1bb7a7a0bac905ab52be123e94af4f68
parentc72fdcb609c56c1793a35ddba2825347473badaf (diff)
downloadaur-a00f2a21de3f401cfea2332b5691b4ea4bde8511.tar.gz
Don't try to use system libssh2 (2.5.10-2)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--gitahead.patch36
3 files changed, 30 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fcb15a56c022..4fdcdb2c509a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gitahead
pkgdesc = Graphical Git client that helps you understand and manage your source history
pkgver = 2.5.10
- pkgrel = 1
+ pkgrel = 2
url = https://www.gitahead.com/
arch = x86_64
license = MIT
@@ -16,7 +16,7 @@ pkgbase = gitahead
source = gitahead.patch
sha256sums = SKIP
sha256sums = 022132e59ea2a1ca43df8ca1e20a1f851fca6e61afe4899814619ca241df7f19
- sha256sums = 0c1320f33acb314b361ff69b4b5fbeda9dfd1a8c59528d27dc37ce111e42ab10
+ sha256sums = 375920168a4f59e41cbf412db787c223d54405799dfcec7dd6ae57eed9d97eb2
pkgname = gitahead
diff --git a/PKGBUILD b/PKGBUILD
index bbcca55fdf80..a47565fc9773 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Angelo Theodorou <encelo@gmail.com>
pkgname=gitahead
-pkgrel=1
+pkgrel=2
pkgver=2.5.10
pkgdesc='Graphical Git client that helps you understand and manage your source history'
url='https://www.gitahead.com/'
@@ -21,7 +21,7 @@ source=(
)
sha256sums=('SKIP'
'022132e59ea2a1ca43df8ca1e20a1f851fca6e61afe4899814619ca241df7f19'
- '0c1320f33acb314b361ff69b4b5fbeda9dfd1a8c59528d27dc37ce111e42ab10')
+ '375920168a4f59e41cbf412db787c223d54405799dfcec7dd6ae57eed9d97eb2')
prepare() {
cd "$srcdir/gitahead"
diff --git a/gitahead.patch b/gitahead.patch
index 07f148e4eef8..d5a672fcc158 100644
--- a/gitahead.patch
+++ b/gitahead.patch
@@ -1,21 +1,37 @@
-diff -urN gitahead/dep/CMakeLists.txt gitahead/dep/CMakeLists.txt
---- gitahead/dep/CMakeLists.txt 2019-03-28 16:25:09.753615593 +0100
-+++ gitahead/dep/CMakeLists.txt 2019-03-28 16:19:28.866933275 +0100
-@@ -1,4 +1,3 @@
+diff --git a/dep/CMakeLists.txt b/dep/CMakeLists.txt
+index d589b6f..02e9035 100644
+--- a/dep/CMakeLists.txt
++++ b/dep/CMakeLists.txt
+@@ -1,6 +1,5 @@
find_package(PkgConfig)
+
-add_subdirectory(openssl)
add_subdirectory(libssh2)
add_subdirectory(libgit2)
-
-diff -urN gitahead/pack/CMakeLists.txt gitahead/pack/CMakeLists.txt
---- gitahead/pack/CMakeLists.txt 2019-03-28 16:06:48.996898436 +0100
-+++ gitahead/pack/CMakeLists.txt 2019-03-28 16:23:57.830278953 +0100
-@@ -147,7 +147,7 @@
+
+diff --git a/dep/libssh2/CMakeLists.txt b/dep/libssh2/CMakeLists.txt
+index d5ee005..6ca9e34 100644
+--- a/dep/libssh2/CMakeLists.txt
++++ b/dep/libssh2/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ if(PKG_CONFIG_FOUND)
+ pkg_check_modules(LIBSSH2 libssh2)
+ endif()
+-if(NOT LIBSSH2_FOUND)
++if(TRUE)
+ set(BUILD_EXAMPLES OFF CACHE BOOL "" FORCE)
+ set(BUILD_TESTING OFF CACHE BOOL "" FORCE)
+
+diff --git a/pack/CMakeLists.txt b/pack/CMakeLists.txt
+index 8cd7ba7..601eb58 100644
+--- a/pack/CMakeLists.txt
++++ b/pack/CMakeLists.txt
+@@ -127,7 +127,7 @@ if(UNIX AND NOT APPLE)
endif()
# Install SSL libraries.
-if(NOT APPLE)
+if(FALSE)
if(WIN32)
- if(CMAKE_CL_64)
+ if(CMAKE_SIZEOF_VOID_P EQUAL 8)
set(SSL_LIB_SUFFIX "-1_1-x64.dll")