summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Schumacher2019-03-31 11:56:52 +0200
committerTim Schumacher2019-03-31 11:56:52 +0200
commita6610277af5bfabb5799058410a41f45dd2ced6a (patch)
tree803a486026546f0a5b20ca72681e354c26c69395
parentcd5560bce122ad37130f0336fb053a8c32a76f0d (diff)
downloadaur-a6610277af5bfabb5799058410a41f45dd2ced6a.tar.gz
Smaller package and other various improvements
From encelo's AUR comment: - Update package URL, description, license and dependencies - Link the binary to system-wide Qt5 and OpenSSL - Avoid compiling and installing OpenSSL - Install license and icons from sources - Delete unused files
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD62
-rw-r--r--README.md19
-rw-r--r--gitahead-license60
-rw-r--r--gitahead.desktop4
-rw-r--r--gitahead.patch20
-rw-r--r--gitahead.pngbin172644 -> 0 bytes
-rw-r--r--gitahead.sh3
-rw-r--r--logo.pngbin3318 -> 0 bytes
9 files changed, 67 insertions, 122 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99713706f686..6abcf7c5fba3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,20 @@
pkgbase = gitahead
- pkgdesc = Understand your Git history!
+ pkgdesc = Graphical Git client that helps you understand and manage your source history
pkgver = 2.5.5
- pkgrel = 1
- url = http://gitahead.scitools.com/
+ pkgrel = 2
+ url = https://www.gitahead.com/
arch = x86_64
- license = custom
+ license = MIT
makedepends = cmake
makedepends = ninja
- depends = curl
+ depends = desktop-file-utils
+ depends = qt5-base
source = git+https://github.com/gitahead/gitahead#tag=v2.5.5
- source = gitahead-license
source = gitahead.desktop
- source = gitahead.png
- source = gitahead.sh
+ source = gitahead.patch
sha256sums = SKIP
- sha256sums = d71bfb48c954d213986816fc29478c7f80c8bd2dd10d2889bf51897d649eedd6
- sha256sums = 6070ebf6752f55f8b7d8a79107ce491c3acf04310eeb9a8242b83cfb4df055f2
- sha256sums = 66cb53fc57eb2ce2e6cd02ff392476fdfb91b723b76ef5da1856e9b5dc1b5c75
- sha256sums = ba4e21c675ce7f49e6df27df1f29d1bb99c47679c4981657a2a4cf5d59930b4a
+ sha256sums = 022132e59ea2a1ca43df8ca1e20a1f851fca6e61afe4899814619ca241df7f19
+ sha256sums = 154bedf8ae6bc8300aa31f92b37acf04bbbc25f8a61a681b72ca360a640fc162
pkgname = gitahead
diff --git a/PKGBUILD b/PKGBUILD
index cbcdce8573c5..472956640880 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,48 +2,39 @@
# Contributor: KillWolfVlad <github.com/KillWolfVlad>
# Contributor: WaveHack <email@wavehack.net>
# Contributor: Whovian9369 <Whovian9369@gmail.com>
+# Contributor: Angelo Theodorou <encelo@gmail.com>
pkgname=gitahead
-pkgrel=1
+pkgrel=2
pkgver=2.5.5
-pkgdesc='Understand your Git history!'
-url='http://gitahead.scitools.com/'
+pkgdesc='Graphical Git client that helps you understand and manage your source history'
+url='https://www.gitahead.com/'
arch=('x86_64')
-license=('custom')
-depends=('curl')
+license=('MIT')
+depends=('desktop-file-utils' 'qt5-base')
makedepends=('cmake' 'ninja')
source=(
"git+https://github.com/gitahead/gitahead#tag=v${pkgver}"
- "gitahead-license"
"gitahead.desktop"
- "gitahead.png"
- "gitahead.sh"
+ "gitahead.patch"
)
sha256sums=('SKIP'
- 'd71bfb48c954d213986816fc29478c7f80c8bd2dd10d2889bf51897d649eedd6'
- '6070ebf6752f55f8b7d8a79107ce491c3acf04310eeb9a8242b83cfb4df055f2'
- '66cb53fc57eb2ce2e6cd02ff392476fdfb91b723b76ef5da1856e9b5dc1b5c75'
- 'ba4e21c675ce7f49e6df27df1f29d1bb99c47679c4981657a2a4cf5d59930b4a')
+ '022132e59ea2a1ca43df8ca1e20a1f851fca6e61afe4899814619ca241df7f19'
+ '154bedf8ae6bc8300aa31f92b37acf04bbbc25f8a61a681b72ca360a640fc162')
prepare() {
cd "$srcdir/gitahead"
+ patch --forward --strip=1 --input="../gitahead.patch"
+
git submodule update --init --recursive
}
build() {
- # Building openssl
- echo "--- Building openssl ---"
- cd "$srcdir/gitahead/dep/openssl/openssl"
- ./config -fPIC
- make
-
- echo "--- Building gitahead ---"
- # Build gitahead
if [ ! -d "$srcdir/gitahead-build" ]; then
mkdir "$srcdir/gitahead-build"
fi
cd "$srcdir/gitahead-build"
- cmake -G Ninja -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${pkgdir}/opt/gitahead" ../gitahead
+ cmake -G Ninja -DCMAKE_BUILD_TYPE=Release -DCMAKE_PREFIX_PATH=/usr/lib -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" ../gitahead
ninja
}
@@ -52,11 +43,30 @@ package() {
ninja install
- # TODO: Figure out how to only call GitAheads install routine
- rm -rf "${pkgdir}/opt/gitahead/"{bin,include,lib,lib64,share}
+ rm -f "${pkgdir}"/usr/*.so.*
+ rm -f "${pkgdir}/usr/bin/cmark"
+ mv "${pkgdir}/usr/GitAhead" "${pkgdir}/usr/bin/gitahead"
+
+ rm -rf "${pkgdir}/usr/include"
+ rm -rf "${pkgdir}"/usr/share/{doc,man}
+ rm -rf "${pkgdir}"/usr/{lib,lib64}
+
+ mkdir -p "${pkgdir}/usr/lib/${pkgname}"
+ mv "${pkgdir}/usr/Plugins" "${pkgdir}/usr/lib/${pkgname}/plugins"
+
+ install -D -m644 "${pkgdir}/usr/Resources/GitAhead.iconset/icon_16x16.png" "${pkgdir}/usr/share/icons/hicolor/16x16/apps/gitahead.png"
+ install -D -m644 "${pkgdir}/usr/Resources/GitAhead.iconset/icon_32x32.png" "${pkgdir}/usr/share/icons/hicolor/32x32/apps/gitahead.png"
+ install -D -m644 "${pkgdir}/usr/Resources/GitAhead.iconset/icon_64x64.png" "${pkgdir}/usr/share/icons/hicolor/64x64/apps/gitahead.png"
+ install -D -m644 "${pkgdir}/usr/Resources/GitAhead.iconset/icon_128x128.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/gitahead.png"
+ install -D -m644 "${pkgdir}/usr/Resources/GitAhead.iconset/icon_256x256.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/gitahead.png"
+ install -D -m644 "${pkgdir}/usr/Resources/GitAhead.iconset/icon_512x512.png" "${pkgdir}/usr/share/icons/hicolor/512x512/apps/gitahead.png"
+ rm -rf "${pkgdir}/usr/Resources/GitAhead.iconset"
+
+ mkdir -p "${pkgdir}/usr/share/${pkgname}"
+ mv "${pkgdir}/usr/Resources" "${pkgdir}/usr/share/${pkgname}/resources"
+
+ rm -f "${pkgdir}"/usr/{git-credential-libsecret,indexer,qt.conf,relauncher}
- install -D -m644 "${srcdir}/gitahead-license" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -D -m755 "${srcdir}/gitahead.sh" "${pkgdir}/usr/bin/gitahead"
+ install -D -m644 ../gitahead/LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m644 "${srcdir}/gitahead.desktop" "${pkgdir}/usr/share/applications/gitahead.desktop"
- install -D -m644 "${srcdir}/gitahead.png" "${pkgdir}/usr/share/pixmaps/gitahead.png"
}
diff --git a/README.md b/README.md
deleted file mode 100644
index 3ac30df51980..000000000000
--- a/README.md
+++ /dev/null
@@ -1,19 +0,0 @@
-# [![logo](logo.png)](http://gitahead.scitools.com) for [AUR](https://aur.archlinux.org/packages/gitahead)
-
-## Installation on Arch Linux (and other Arch-Based distributions)
-
-```bash
-$ makepkg -is
-```
-
-## Need help or you want help?
-
-1. Open issue
-2. Send PR
-3. Or write me to [vk](https://vk.com/killwolfvlad)
-
-## Clear your home after GitAhead
-
-```bash
-$ rm -rf ~/.config/gitahead.com ~/.local/share/GitAhead
-```
diff --git a/gitahead-license b/gitahead-license
deleted file mode 100644
index 5419789445c2..000000000000
--- a/gitahead-license
+++ /dev/null
@@ -1,60 +0,0 @@
-SCIENTIFIC TOOLWORKS, INC.
-SOFTWARE LICENSE AGREEMENT
-
-Software Product(s): GitAhead
-
-IMPORTANT. READ CAREFULLY: This License Agreement ("AGREEMENT") is a legal agreement between you ("you") as the end user (either an individual, firm or entity), and Scientific Toolworks, Inc. ("SciTools"). This AGREEMENT covers the SciTools software product(s) identified above, which includes "online" or electronic documentation and may include computer software and associated media and printed materials (collectively, the "SOFTWARE PRODUCT" or "SOFTWARE"). By installing, downloading, copying, accessing, or otherwise using the SOFTWARE PRODUCT, you agree to be bound by the terms of this AGREEMENT. If you do not agree to the terms of this AGREEMENT, you are not authorized to download, install, or otherwise use any of the SOFTWARE PRODUCT. This is a legal agreement enforceable by laws of the State of New Hampshire, the United States of America and other countries. Be sure to read this entire AGREEMENT before downloading, installing, or otherwise using the SOFTWARE.
-
-The SOFTWARE PRODUCT is licensed, not sold, on the following terms and conditions:
-
-1. GRANT OF LICENSE.
-
-a. General License Grant. Pursuant to a purchase order for the SOFTWARE ("Purchase Order"), and subject to payment of all applicable license fees and other charges, SciTools grants you a limited, non-transferable (except as set forth herein), non-exclusive license to use the SOFTWARE PRODUCT for your own internal business functions in accordance with the terms, conditions, and restrictions of this AGREEMENT.
-
-b. License Options. Your license to use the software shall be a single developer license ("SDL"), a floating license ("Floating License"), or a node-lock license ("Node License"), each as described below, and subject to the provisions set forth below. The type of license you have shall be set forth on the Purchase Order for the SOFTWARE.
-i. Single Developer License. If your license is a SDL, then only the single individual named in the Purchase Order (or otherwise provided in writing to SciTools) may use the SOFTWARE. Such individual may use the SOFTWARE on one or more computers, but may not allow any other individual or entity to use the SOFTWARE. This SDL may be transferred, upon written notice to SciTools (but without having to obtain SciTools' consent), to another individual (A) within the same company as the original licensee, and (B) who is providing services for the same project on which the original licensee was working on the date this license commenced. This SDL may not be transferred to any other individual or to any corporation, limited liability company, partnership, or any other entity without SciTools' prior written consent.
-ii. Floating License. If your license is a Floating License, then the SOFTWARE may be used subject to the control of SciTools' software license manager software that permits one individual user concurrently per license. This Floating License may not be transferred to another entity without SciTools' prior written consent.
-iii. Node License. If your license is a Node License, then the SOFTWARE may be used subject to the control of SciTools' software license manager software configured to permit one user to use the SOFTWARE on the computer on which the SOFTWARE is installed. This license may not be transferred to any other computer or entity unless SciTools consents in writing.
-c. Ownership of the SOFTWARE. You acknowledge that SciTools has a valuable proprietary interest in the SOFTWARE PRODUCT. SciTools retains title to and all copyright and other intellectual property rights in the SOFTWARE PRODUCTS. You are not granted any right, title, or interest in the SOFTWARE PRODUCT, except the right to use the SOFTWARE PRODUCTS in accordance with this AGREEMENT.
-
- d. Term and Termination of License.
-
- i. The term of this AGREEMENT, and the license granted hereunder, shall commence upon your installation of the SOFTWARE.
-
-ii. This AGREEMENT and the license granted hereunder shall terminate immediately and automatically if you have not paid any license fees or other charges due to SciTools within 30 days after such amount is due.
-
-iii. Without prejudice to any other rights, SciTools may terminate this AGREEMENT and the license granted hereunder if you breach any of the provisions of this AGREEMENT or otherwise fail to comply with the terms and conditions of this AGREEMENT.
-
-iv. Upon termination of the license for any reason, you must immediately destroy all copies of the SOFTWARE PRODUCT (including purging all storage media on which such SOFTWARE is installed or otherwise stored) and all of its component parts.
-
-v. Upon termination of this Agreement, the provisions of Section 2, 3, 5, 6, 7, 8 and 9 shall survive.
-
-2. DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS.
-
-a. Limitations on Reverse Engineering, Decompilation, and Disassembly. You may not reverse engineer, decompile, or disassemble the SOFTWARE PRODUCT, except and only to the extent that such activity is expressly permitted by applicable law notwithstanding this limitation.
-
-b. Copies; Copyright Notices. You may not copy the SOFTWARE PRODUCT except for (i) such copies as may be generated as part of the normal operation of the SOFTWARE, or (ii) a reasonable number of back-up copies for disaster recovery purposes. You must maintain all copyright notices on all back-up copies of the SOFTWARE PRODUCT.
-
-c. No Distribution. You may not distribute copies of the SOFTWARE PRODUCT to third parties.
-
-d. Limited Use. You may use the SOFTWARE PRODUCT only for your own internal business purposes, and you may not use the SOFTWARE PRODUCT in any service bureau or similar application or otherwise to provide software analysis or other services to any third party. You may not rent, lease or lend the SOFTWARE PRODUCT or otherwise permit a third party to use the SOFTWARE PRODUCT.
-
-e. No Transfer. Except as specifically set forth in Section 1(b) above, you may not transfer the SOFTWARE, license, or any other rights to a third party.
-
-3. COPYRIGHT. All title, copyrights, and all other intellectual property rights in and to the SOFTWARE PRODUCT, the accompanying printed materials, and any copies of the SOFTWARE PRODUCT are owned by SciTools or its suppliers. The SOFTWARE PRODUCT is protected by copyright laws and international treaty provisions.
-
-4. U.S. GOVERNMENT RESTRICTED RIGHTS. The SOFTWARE PRODUCT and documentation are "commercial computer software" and are provided with RESTRICTED RIGHTS. Use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraphs (c)(1) and (2) of the Commercial Computer Software Restricted Rights at 48 CFR 52.227-19, as applicable. Manufacturer is Scientific Toolworks, Inc., 53 N Main, St George, UT 84770.
-
-5. NO WARRANTIES.
-
-a. SciTools expressly disclaims any and all warranties for the SOFTWARE PRODUCT. Without limiting the generality of the foregoing, SciTools does not warrant that the functions contained in the SOFTWARE will meet your requirements or that the operation of the SOFTWARE will be uninterrupted or error-free. You assume the entire risk as to the installation and use of the SOFTWARE PRODUCT.
-
-b. THE SOFTWARE PRODUCT AND ANY RELATED DOCUMENTATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NON-INFRINGEMENT.
-
-6. LIMITATION OF LIABILITY. In no event shall SciTools, or its resellers, suppliers, or distributors, be liable for direct damages in excess of the license fee paid by you. In addition, in no event shall SciTools, or its resellers, suppliers, or distributors, be liable for any consequential, incidental, special or indirect damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business information, or any other pecuniary loss) arising out of the use of or inability to use the SOFTWARE, even if SciTools has been advised of the possibility of such damages.
-
-7. INDEMNIFICATION. You agree to indemnify, defend and hold harmless SciTools and its officers, directors, employees, agents, resellers, distributors, and suppliers from any damages, losses or expenses (including reasonable attorneys' fees) incurred by any such indemnitee arising from or related to your use of the SOFTWARE PRODUCT.
-
-8. TAXES. You agree to be responsible for and to pay, and to reimburse SciTools on request if SciTools is required to pay, any tax (excluding only any tax that is based solely on SciTools' net income), assessment, duty, tariff, or other fee or charge of any kind or nature levied or imposed by any governmental authority pertaining in any way to your purchase of this SOFTWARE PRODUCT, the license, or your use of the SOFTWARE.
-
-9. MISCELLANEOUS. This AGREEMENT is governed by the laws of the State of New Hampshire, USA. This AGREEMENT is the complete and exclusive statement of the agreement between SciTools and you, and this AGREEMENT supersedes any prior proposal, agreement, or communication, oral or written, pertaining to the subject matter of this AGREEMENT. No waiver by SciTools of any breach hereunder shall be deemed to be a waiver of any other breach of the same or any other nature. If any provision of this AGREEMENT is deemed invalid by any court having jurisdiction, that particular provision will be deemed deleted and will not affect the validity of any other provision of this AGREEMENT. Should you have any questions concerning this AGREEMENT, or if you desire to contact SciTools for any reason, please contact SciTools at: Scientific Toolworks, Inc., 53 N Main, St George, UT 84770, or via SciTools' website at www.scitools.com.
diff --git a/gitahead.desktop b/gitahead.desktop
index 8e4bb45c40ef..5857d80bd470 100644
--- a/gitahead.desktop
+++ b/gitahead.desktop
@@ -1,10 +1,10 @@
[Desktop Entry]
Name=GitAhead
-Comment=THE MOST POWERFUL GIT GUI
+Comment=Graphical Git client
Exec=gitahead
Icon=gitahead
Terminal=false
Type=Application
StartupNotify=true
Categories=GNOME;GTK;Development;Documentation;
-MimeType=text/plain;
+MimeType=text/plain; \ No newline at end of file
diff --git a/gitahead.patch b/gitahead.patch
new file mode 100644
index 000000000000..4e9d8e6767b9
--- /dev/null
+++ b/gitahead.patch
@@ -0,0 +1,20 @@
+diff -urN gitahead/dep/CMakeLists.txt gitahead/dep/CMakeLists.txt
+--- gitahead/dep/CMakeLists.txt 2019-03-28 16:25:09.753615593 +0100
++++ gitahead/dep/CMakeLists.txt 2019-03-28 16:19:28.866933275 +0100
+@@ -1,4 +1,3 @@
+-add_subdirectory(openssl)
+ add_subdirectory(libssh2)
+ add_subdirectory(libgit2)
+
+diff -urN gitahead/pack/CMakeLists.txt gitahead/pack/CMakeLists.txt
+--- gitahead/pack/CMakeLists.txt 2019-03-28 16:06:48.996898436 +0100
++++ gitahead/pack/CMakeLists.txt 2019-03-28 16:23:57.830278953 +0100
+@@ -147,7 +147,7 @@
+ endif()
+
+ # Install SSL libraries.
+-if(NOT APPLE)
++if(FALSE)
+ if(WIN32)
+ if(CMAKE_CL_64)
+ set(SSL_LIB_SUFFIX "-1_1-x64.dll") \ No newline at end of file
diff --git a/gitahead.png b/gitahead.png
deleted file mode 100644
index 894f6d36d7b1..000000000000
--- a/gitahead.png
+++ /dev/null
Binary files differ
diff --git a/gitahead.sh b/gitahead.sh
deleted file mode 100644
index cc8ba904a9db..000000000000
--- a/gitahead.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/usr/bin/env bash
-
-exec /opt/gitahead/GitAhead "$@"
diff --git a/logo.png b/logo.png
deleted file mode 100644
index f026007b8f83..000000000000
--- a/logo.png
+++ /dev/null
Binary files differ