aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKillWolfVlad2017-10-12 00:26:11 +0500
committerKillWolfVlad2017-10-12 00:26:11 +0500
commit93930cb860c1d57460210ae7f44d30cee6d26d55 (patch)
treefb80851960cc1a1efa2fe2f627ff5db830e8d0e9
parent2badb494bbf72dda70ffb07cb84fe51a5c533d31 (diff)
downloadaur-93930cb860c1d57460210ae7f44d30cee6d26d55.tar.gz
Bump to v1.4.5-1
-rw-r--r--.SRCINFO7
-rw-r--r--CHANGELOG.md17
-rw-r--r--PKGBUILD15
3 files changed, 29 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5a893b12d5a..4cb302139e56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = gitahead
pkgdesc = THE MOST POWERFUL GIT GUI
- pkgver = 1.4.4
+ pkgver = 1.4.5
pkgrel = 1
url = http://gitahead.scitools.com/
arch = x86_64
license = custom
+ depends = qt5-base
provides = gitahead
conflicts = gitahead
- source = gitahead-1.4.4.bin::https://gitahead.com/downloads/v1.4.4/GitAhead-1.4.4.sh
+ source = gitahead-1.4.5.bin::https://gitahead.com/downloads/v1.4.5/GitAhead-1.4.5.sh
source = gitahead-license
source = gitahead.desktop
source = gitahead.png
source = gitahead.sh
- sha256sums = e6f5f02d15c896b986be818c02721e253f53ec4378272615f68deee67f765d2b
+ sha256sums = efa825d76841d28ca3b84db7f42cf39155bb75962368bbe05178cb2d8d8d4060
sha256sums = d71bfb48c954d213986816fc29478c7f80c8bd2dd10d2889bf51897d649eedd6
sha256sums = 6070ebf6752f55f8b7d8a79107ce491c3acf04310eeb9a8242b83cfb4df055f2
sha256sums = 66cb53fc57eb2ce2e6cd02ff392476fdfb91b723b76ef5da1856e9b5dc1b5c75
diff --git a/CHANGELOG.md b/CHANGELOG.md
index b9a5fc222ceb..96fef42c8f3c 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,3 +1,20 @@
+# [v1.4.5 - 2017-10-10](https://gitahead.com/cgi-bin/update.py?platform=linux&version=1.4.4)
+
+## Added
+
+- Added option to merge without committing.
+- Added context menu actions to stage/unstage multiple files at once.
+
+## Fixed
+
+- Fixed usability issues in the custom external tools editor interface.
+- Don't yield focus to the commit message editor when staging files with the keyboard.
+- Fixed state of stash toolbar button and menu item when the working directory is clean except for untracked files.
+- Fixed failure to cherry-pick and revert when the working directory is dirty.
+- Fixed hang on some diffs.
+- Fixed garbage remote transfer rate when the elapsed time is too small to measure.
+- (Mac) Fixed several issues on macOS 10.13.
+
# [v1.4.4 - 2017-09-22](https://gitahead.com/cgi-bin/update.py?platform=linux&version=1.4.3)
## Added
diff --git a/PKGBUILD b/PKGBUILD
index 69cbc4f4b3d0..8728528f2ca0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
pkgname=('gitahead')
pkgrel=1
-pkgver=1.4.4
+pkgver=1.4.5
pkgdesc='THE MOST POWERFUL GIT GUI'
url='http://gitahead.scitools.com/'
provides=('gitahead')
conflicts=('gitahead')
arch=('x86_64')
license=('custom')
+depends=('qt5-base')
source=(
"gitahead-${pkgver}.bin::https://gitahead.com/downloads/v${pkgver}/GitAhead-${pkgver}.sh"
"gitahead-license"
@@ -16,7 +17,7 @@ source=(
"gitahead.png"
"gitahead.sh"
)
-sha256sums=('e6f5f02d15c896b986be818c02721e253f53ec4378272615f68deee67f765d2b'
+sha256sums=('efa825d76841d28ca3b84db7f42cf39155bb75962368bbe05178cb2d8d8d4060'
'd71bfb48c954d213986816fc29478c7f80c8bd2dd10d2889bf51897d649eedd6'
'6070ebf6752f55f8b7d8a79107ce491c3acf04310eeb9a8242b83cfb4df055f2'
'66cb53fc57eb2ce2e6cd02ff392476fdfb91b723b76ef5da1856e9b5dc1b5c75'
@@ -29,13 +30,13 @@ prepare() {
}
package() {
- install -d "${pkgdir}/opt"
- cp -R "${srcdir}/gitahead-${pkgver}" "${pkgdir}/opt/gitahead"
-
+ install -d "${pkgdir}/opt/gitahead"
+ cp -R "${srcdir}/gitahead-${pkgver}/Resources" "${pkgdir}/opt/gitahead"
find "${pkgdir}/opt/gitahead/" -type f -exec chmod 644 {} \;
- chmod 755 "${pkgdir}/opt/gitahead/GitAhead"
- install -d "${pkgdir}/usr/bin"
+ install -D -m755 "${srcdir}/gitahead-${pkgver}/GitAhead" "${pkgdir}/opt/gitahead/GitAhead"
+ install -D -m755 "${srcdir}/gitahead-${pkgver}/indexer" "${pkgdir}/opt/gitahead/indexer"
+ install -D -m755 "${srcdir}/gitahead-${pkgver}/relauncher" "${pkgdir}/opt/gitahead/relauncher"
install -D -m644 "${srcdir}/gitahead-license" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m755 "${srcdir}/gitahead.sh" "${pkgdir}/usr/bin/gitahead"