summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen James2015-06-17 18:57:34 -0500
committerBen James2015-06-17 18:57:34 -0500
commite2d739bf3032c77a52969f3a25ac8a51e3be88d1 (patch)
treef05a7466ae29b58b8cf76c9ef1b770760ce7f53b
downloadaur-e2d739bf3032c77a52969f3a25ac8a51e3be88d1.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07a4c9b6d229
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gitd
+ pkgdesc = A way of notifying you of git commits
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/benjamin-james/gitd
+ arch = any
+ license = GPL3
+ makedepends = autoconf
+ depends = git
+ depends = glibc
+ optdepends = libnotify: the default notifier for gitd through notify-send
+ provides = gitd
+ source = https://github.com/benjamin-james/gitd/releases/download/0.2.0/gitd-0.2.0.tar.xz
+ md5sums = 2cbd1094d858658ddef3ddba312101c3
+
+pkgname = gitd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2e1c44211a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Benjamin James <benjamin-james@utulsa.edu>
+
+pkgname=gitd
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A way of notifying you of git commits"
+arch=('any')
+url="https://github.com/benjamin-james/gitd"
+license=('GPL3')
+depends=('git' 'glibc')
+makedepends=('autoconf')
+optdepends=('libnotify: the default notifier for gitd through notify-send')
+provides=('gitd')
+source=(https://github.com/benjamin-james/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz)
+md5sums=('2cbd1094d858658ddef3ddba312101c3')
+build() {
+ cd "${pkgname}"
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}/" install
+ install -D -m644 gitd.service "${pkgdir}/usr/lib/systemd/system/gitd.service"
+}