summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrederik2017-10-13 18:37:34 +0200
committerfrederik2017-10-13 18:37:34 +0200
commit06cd90fb7816946cf32cc48a5477c4025e78fa26 (patch)
tree52c6b80e2c6cfde82142bb2d7f5aa1c6dffc7f87
parent77f2e772556c3b811a7284a8cf8d629b7582b477 (diff)
downloadaur-06cd90fb7816946cf32cc48a5477c4025e78fa26.tar.gz
upgrade to 1.2.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
-rw-r--r--app.ini92
3 files changed, 94 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8804664860c1..5d665f7fb410 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Sep 4 14:40:00 UTC 2017
+# Fri Oct 13 16:37:32 UTC 2017
pkgbase = gitea
pkgdesc = Git with a cup of tea, forked from Gogs. Is a Self Hosted Git Service in the Go Programming Language.
- pkgver = 1.1.4
+ pkgver = 1.2.0
pkgrel = 1
url = http://gitea.io
install = gitea.install
@@ -11,6 +11,7 @@ pkgbase = gitea
arch = arm
arch = armv6h
arch = armv7h
+ arch = aarch64
license = MIT
makedepends = go
makedepends = git
@@ -24,12 +25,12 @@ pkgbase = gitea
conflicts = gitea-git
conflicts = gitea-git-dev
backup = etc/gitea/app.ini
- source = https://github.com/go-gitea/gitea/archive/v1.1.4.tar.gz
+ source = https://github.com/go-gitea/gitea/archive/v1.2.0.tar.gz
source = gitea.service
source = app.ini
- sha512sums = 4427c4c1a588dcf201f707c3e2827fd702a0f8c0add63c6a5eff0d6ef8d21fdaaaf275f8e790017751f161431d563df22f71a6ea046085f9fb1d57da99f20524
+ sha512sums = 801de93ceecbe58e7303109a21c5e08cf17c6968a675b40b12a0cffdf5cefaa1cf9285143bbe297944f15128f6ffdf8aed0ffa0dcbf2819241dff11d9cea0ddc
sha512sums = 692ea79b3195f3222f69b485f8a7905223fa457dc5cb2b480edbac6f480ac4f74075accb04ae0c17b90e98e41f53224e661a85762310d7263921e763cb3fc257
- sha512sums = f72a6ea944e9f6b55c33a1b8f7bf5ff3c2f6dd6e12e3ab0702c74ec2e4ce6c7190aaf97676c3408004089688b91ead04f8a8054906aa73ebf4034fbf0d9d1104
+ sha512sums = 03f2947aa80c1f9a9390b1d9fcce8bd7c930b6ae1afb9ee971666e7259992fe1d4e71584a1268abb2283add8d746aca1749e0b6e7355a7404edeb65d62efea63
pkgname = gitea
diff --git a/PKGBUILD b/PKGBUILD
index ef4cf824de66..6588c5164a85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Frederik Schwan <frederik dot schwan at linux dot com>
pkgname=gitea
-pkgver=1.1.4
+pkgver=1.2.0
pkgrel=1
pkgdesc='Git with a cup of tea, forked from Gogs. Is a Self Hosted Git Service in the Go Programming Language.'
-arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url='http://gitea.io'
license=('MIT')
makedepends=('go' 'git')
@@ -21,9 +21,9 @@ install=gitea.install
source=(https://github.com/go-gitea/gitea/archive/v${pkgver}.tar.gz
gitea.service
app.ini)
-sha512sums=('4427c4c1a588dcf201f707c3e2827fd702a0f8c0add63c6a5eff0d6ef8d21fdaaaf275f8e790017751f161431d563df22f71a6ea046085f9fb1d57da99f20524'
+sha512sums=('801de93ceecbe58e7303109a21c5e08cf17c6968a675b40b12a0cffdf5cefaa1cf9285143bbe297944f15128f6ffdf8aed0ffa0dcbf2819241dff11d9cea0ddc'
'692ea79b3195f3222f69b485f8a7905223fa457dc5cb2b480edbac6f480ac4f74075accb04ae0c17b90e98e41f53224e661a85762310d7263921e763cb3fc257'
- 'f72a6ea944e9f6b55c33a1b8f7bf5ff3c2f6dd6e12e3ab0702c74ec2e4ce6c7190aaf97676c3408004089688b91ead04f8a8054906aa73ebf4034fbf0d9d1104')
+ '03f2947aa80c1f9a9390b1d9fcce8bd7c930b6ae1afb9ee971666e7259992fe1d4e71584a1268abb2283add8d746aca1749e0b6e7355a7404edeb65d62efea63')
prepare() {
mkdir -p "${srcdir}/src/code.gitea.io"
@@ -45,7 +45,7 @@ package() {
install -Dm755 "${srcdir}/src/code.gitea.io/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 "${srcdir}/gitea.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
install -Dm644 "${srcdir}/src/code.gitea.io/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 "${srcdir}/app.ini" "${pkgdir}/etc/gitea/app.ini"
+ install -Dm664 "${srcdir}/app.ini" "${pkgdir}/etc/gitea/app.ini"
cp -r "${srcdir}/src/code.gitea.io/${pkgname}/"{templates,options,public} "${pkgdir}/var/lib/${pkgname}"
cp -r "${srcdir}/src/code.gitea.io/${pkgname}/options/locale" "${pkgdir}/var/lib/${pkgname}/conf"
diff --git a/app.ini b/app.ini
index d6bbe352c694..bccd8e60e30a 100644
--- a/app.ini
+++ b/app.ini
@@ -32,6 +32,10 @@ LINE_WRAP_EXTENSIONS = .txt,.md,.markdown,.mdown,.mkd,
; Separate values by commas. Preview tab in edit mode won't show if the file extension doesn't match
PREVIEWABLE_FILE_MODES = markdown
+[repository.local]
+; Path for uploads. Defaults to `tmp/local-repo`
+LOCAL_COPY_PATH = /var/lib/gitea/tmp/local-repo/
+
[repository.upload]
; Whether repository file uploads are enabled. Defaults to `true`
ENABLED = true
@@ -74,6 +78,11 @@ ORG_PAGING_NUM = 50
; Number of repos that are showed in one page
REPO_PAGING_NUM = 15
+[ui.meta]
+AUTHOR = Gitea - Git with a cup of tea
+DESCRIPTION = Gitea (Git with a cup of tea) is a painless self-hosted Git service written in Go
+KEYWORDS = go,git,self-hosted,gitea
+
[markdown]
; Enable hard line break extension
ENABLE_HARD_LINE_BREAK = false
@@ -85,9 +94,11 @@ CUSTOM_URL_SCHEMES =
FILE_EXTENSIONS = .md,.markdown,.mdown,.mkd
[server]
+; Listen protocol. One of 'http', 'https', 'unix' or 'fcgi'.
PROTOCOL = http
DOMAIN = localhost
ROOT_URL = %(PROTOCOL)s://%(DOMAIN)s:%(HTTP_PORT)s/
+; Listen address. Either a IPv4/IPv6 address or the path to a unix socket.
HTTP_ADDR = 0.0.0.0
HTTP_PORT = 3000
; Permission for unix socket
@@ -110,11 +121,15 @@ SSH_PORT = 22
SSH_LISTEN_PORT = %(SSH_PORT)s
; Root path of SSH directory, default is '~/.ssh', but you have to use '/home/git/.ssh'.
SSH_ROOT_PATH =
-; Directory to create temporary files when test publick key using ssh-keygen,
+; Directory to create temporary files when test public key using ssh-keygen,
; default is system temporary directory.
SSH_KEY_TEST_PATH =
; Path to ssh-keygen, default is 'ssh-keygen' and let shell find out which one to call.
SSH_KEYGEN_PATH = ssh-keygen
+; Enable SSH Authorized Key Backup when rewriting all keys, default is true
+SSH_BACKUP_AUTHORIZED_KEYS = true
+; Enable exposure of SSH clone URL to anonymous visitors, default is false
+SSH_EXPOSE_ANONYMOUS = false
; Indicate whether to check minimum key size with corresponding type
MINIMUM_KEY_SIZE_CHECK = false
; Disable CDN even in "prod" mode
@@ -138,6 +153,12 @@ APP_DATA_PATH = /var/lib/gitea/data/
ENABLE_GZIP = false
; Landing page for non-logged users, can be "home" or "explore"
LANDING_PAGE = home
+; Enables git-lfs support. true or false, default is false.
+LFS_START_SERVER = false
+; Where your lfs files put on, default is data/lfs.
+LFS_CONTENT_PATH = data/lfs
+; LFS authentication secret, changed this to yourself.
+LFS_JWT_SECRET =
; Define allowed algorithms and their minimum key length (use -1 to disable a type)
[ssh.minimum_key_sizes]
@@ -147,7 +168,7 @@ RSA = 2048
DSA = 1024
[database]
-; Either "mysql", "postgres" or "sqlite3", it's your choice
+; Either "mysql", "postgres", "mssql" or "sqlite3", it's your choice
DB_TYPE = mysql
HOST = 127.0.0.1:3306
NAME = gitea
@@ -157,6 +178,8 @@ PASSWD =
SSL_MODE = disable
; For "sqlite3" and "tidb", use absolute path when you start as service
PATH = data/gitea.db
+; For "sqlite3" only. Query timeout
+SQLITE_TIMEOUT = 500
[indexer]
ISSUE_INDEXER_PATH = /var/lib/gitea/indexer/issues.bleve
@@ -182,8 +205,44 @@ MIN_PASSWORD_LENGTH = 6
; True when users are allowed to import local server paths
IMPORT_LOCAL_PATHS = false
+[openid]
+;
+; OpenID is an open standard and decentralized authentication protocol.
+; Your identity is the address of a webpage you provide, which describes
+; how to prove you are in control of that page.
+;
+; For more info: https://en.wikipedia.org/wiki/OpenID
+;
+; Current implementation supports OpenID-2.0
+;
+; Tested to work providers at the time of writing:
+; - Any GNUSocial node (your.hostname.tld/username)
+; - Any SimpleID provider (http://simpleid.koinic.net)
+; - http://openid.org.cn/
+; - openid.stackexchange.com
+; - login.launchpad.net
+; - <username>.livejournal.com
+;
+; Whether to allow signin in via OpenID
+ENABLE_OPENID_SIGNIN = true
+; Whether to allow registering via OpenID
+; Do not include to rely on DISABLE_REGISTRATION setting
+;ENABLE_OPENID_SIGNUP = true
+; Allowed URI patterns (POSIX regexp).
+; Space separated.
+; Only these would be allowed if non-blank.
+; Example value: trusted.domain.org trusted.domain.net
+WHITELISTED_URIS =
+; Forbidden URI patterns (POSIX regexp).
+; Space sepaated.
+; Only used if WHITELISTED_URIS is blank.
+; Example value: loadaverage.org/badguy stackexchange.com/.*spammer
+BLACKLISTED_URIS =
+
[service]
+; Time limit to confirm account/email registration
ACTIVE_CODE_LIVE_MINUTES = 180
+; Time limit to confirm forgot password reset process
RESET_PASSWD_CODE_LIVE_MINUTES = 180
; User need to confirm e-mail for registration
REGISTER_EMAIL_CONFIRM = false
@@ -201,6 +260,9 @@ ENABLE_CAPTCHA = true
; Default value for KeepEmailPrivate
; New user will get the value of this setting copied into their profile
DEFAULT_KEEP_EMAIL_PRIVATE = false
+; Default value for AllowCreateOrganization
+; New user will have rights set to create organizations depending on this setting
+DEFAULT_ALLOW_CREATE_ORGANIZATION = true
; Default value for the domain part of the user's email address in the git log
; if he has set KeepEmailPrivate true. The user's email replaced with a
; concatenation of the user name in lower case, "@" and NO_REPLY_ADDRESS.
@@ -242,8 +304,8 @@ FROM =
; Mailer user name and password
USER =
PASSWD =
-; Use text/html as alternative format of content
-ENABLE_HTML_ALTERNATIVE = false
+; Send mails as plain text
+SEND_AS_PLAIN_TEXT = false
; Enable sendmail (override SMTP)
USE_SENDMAIL = false
; Specifiy an alternative sendmail binary
@@ -274,9 +336,9 @@ COOKIE_NAME = i_like_gitea
COOKIE_SECURE = false
; Enable set cookie, default is true
ENABLE_SET_COOKIE = true
-; Session GC time interval, default is 86400
+; Session GC time interval in seconds, default is 86400 (1 day)
GC_INTERVAL_TIME = 86400
-; Session life time, default is 86400
+; Session life time in seconds, default is 86400 (1 day)
SESSION_LIFE_TIME = 86400
[picture]
@@ -400,13 +462,23 @@ SCHEDULE = @every 24h
; Archives created more than OLDER_THAN ago are subject to deletion
OLDER_THAN = 24h
+; Synchronize external user data (only LDAP user synchronization is supported)
+[cron.sync_external_users]
+; Syncronize external user data when starting server (default false)
+RUN_AT_START = false
+; Interval as a duration between each synchronization (default every 24h)
+SCHEDULE = @every 24h
+; Create new users, update existing user data and disable users that are not in external source anymore (default)
+; or only create new users if UPDATE_EXISTING is set to false
+UPDATE_EXISTING = true
+
[git]
; Disables highlight of added and removed changes
DISABLE_DIFF_HIGHLIGHT = false
; Max number of lines allowed of a single file in diff view
MAX_GIT_DIFF_LINES = 1000
; Max number of characters of a line allowed in diff view
-MAX_GIT_DIFF_LINE_CHARACTERS = 500
+MAX_GIT_DIFF_LINE_CHARACTERS = 5000
; Max number of files shown in diff view
MAX_GIT_DIFF_FILES = 100
; Arguments for command 'git gc', e.g. "--aggressive --auto"
@@ -422,8 +494,10 @@ PULL = 300
GC = 60
[mirror]
-; Default interval in hours between each check
-DEFAULT_INTERVAL = 8
+; Default interval as a duration between each check
+DEFAULT_INTERVAL = 8h
+; Min interval as a duration must be > 1m
+MIN_INTERVAL = 10m
[api]
; Max number of items will response in a page