summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrederik2017-01-05 17:30:17 +0100
committerfrederik2017-01-05 17:30:17 +0100
commit27b5dce25e82993950078de77fad269edd97cf8d (patch)
tree4bd8772c857dab3956bebeb4a6bb5e36ec0c4a2f
parent6a165a03f999ed4bdf72929d63eccb21ac9bf2a0 (diff)
downloadaur-27b5dce25e82993950078de77fad269edd97cf8d.tar.gz
bump to 1.0.1
-rw-r--r--PKGBUILD8
-rw-r--r--app.ini11
2 files changed, 14 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2d12c6b0a1d..2430a5133ec9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Frederik Schwan <frederik dot schwan at linux dot com>
pkgname=gitea
-pkgver=1.0.0
-pkgrel=2
+pkgver=1.0.1
+pkgrel=1
pkgdesc='Git with a cup of tea, forked from Gogs. Is a Self Hosted Git Service in the Go Programming Language.'
arch=('x86_64' 'i686')
url='http://gitea.io'
@@ -22,9 +22,9 @@ backup=('etc/gitea/app.ini')
source=(https://github.com/go-gitea/gitea/releases/download/v${pkgver}/${pkgname}-${pkgver}-linux-amd64
gitea.service
app.ini)
-sha512sums=('b1b415b6f513290e46ac6515bdfefa199fdc6485b0c1b8174955b656e95612bd37d9d1c005e1e6451561a3ffdb419c8807062fbedc6a6806e3bab8bc4c69eceb'
+sha512sums=('c2b6615248fa8bce30e7c04b6d715d8dba0720e7c0915f17d2f3a5ea122a9d88247d5c651ad0d303a293803ece02f0f2329cadfe1d9f495b23a8a8104b8a37b7'
'692ea79b3195f3222f69b485f8a7905223fa457dc5cb2b480edbac6f480ac4f74075accb04ae0c17b90e98e41f53224e661a85762310d7263921e763cb3fc257'
- '4652e99597b8f3bb4ab8f9ec4e6e32ff8b5f6a3a365f6b0a0af57c19f18b29b6eb1985bc99dd72b7ded2ca12eb5cd24d56daca4956bddd5ab808cb57c0bb52fe')
+ 'de2b72913dbb97b0b66b2b50a98d8d3b88451adc83c82e81bd336eb1b3408ea7eb308fff623b175aeb009d727f4fb4aa916050428914044f57ff849cce376574')
package() {
install -o git -g git -d -m 750 ${pkgdir}/var/lib/gitea/
diff --git a/app.ini b/app.ini
index e8b197ac7de3..a08037ed274c 100644
--- a/app.ini
+++ b/app.ini
@@ -57,6 +57,8 @@ FEED_MAX_COMMIT_NUM = 5
THEME_COLOR_META_TAG = `#6cc644`
; Max size of files to be displayed (defaults is 8MiB)
MAX_DISPLAY_FILE_SIZE = 8388608
+; Whether show the user email in the Explore Users page
+SHOW_USER_EMAIL = true
[ui.admin]
; Number of users that are showed in one page
@@ -159,6 +161,7 @@ PATH = data/gitea.db
[admin]
[security]
+; Whether the installer is disabled
INSTALL_LOCK = false
; !!CHANGE THIS TO KEEP YOUR USER DATA SAFE!!
SECRET_KEY = !#@FDEWREWR&*(
@@ -168,6 +171,8 @@ COOKIE_USERNAME = gitea_awesome
COOKIE_REMEMBER_NAME = gitea_incredible
; Reverse proxy authentication header name of user name
REVERSE_PROXY_AUTHENTICATION_USER = X-WEBAUTH-USER
+; Sets the minimum password length for new Users
+MIN_PASSWORD_LENGTH = 6
[service]
ACTIVE_CODE_LIVE_MINUTES = 180
@@ -224,6 +229,10 @@ USER =
PASSWD =
; Use text/html as alternative format of content
ENABLE_HTML_ALTERNATIVE = false
+; Enable sendmail (override SMTP)
+USE_SENDMAIL = false
+; Specifiy an alternative sendmail binary
+SENDMAIL_PATH = sendmail
[cache]
; Either "memory", "redis", or "memcache", default is "memory"
@@ -245,7 +254,7 @@ PROVIDER = memory
; mysql: go-sql-driver/mysql dsn config string, e.g. `root:password@/session_table`
PROVIDER_CONFIG = /var/lib/gitea/sessions
; Session cookie name
-COOKIE_NAME = i_like_gogits
+COOKIE_NAME = i_like_gitea
; If you use session in https only, default is false
COOKIE_SECURE = false
; Enable set cookie, default is true