summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrederik2017-11-30 00:42:38 +0100
committerfrederik2017-11-30 00:42:38 +0100
commit8d535b1d7e5e354b447871776e5df62a71d03740 (patch)
treef9840325451e7bf9f20bec82399ab7abcb0f1b8b
parent6cb3115e4782807012c1ae6c4f8c75d63d55c8f3 (diff)
downloadaur-8d535b1d7e5e354b447871776e5df62a71d03740.tar.gz
upgrade to 1.3.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--app.ini53
3 files changed, 55 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53be677e467b..41db219ef7e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Nov 3 14:19:55 UTC 2017
+# Wed Nov 29 23:42:20 UTC 2017
pkgbase = gitea
pkgdesc = Git with a cup of tea, forked from Gogs. Is a Self Hosted Git Service in the Go Programming Language.
- pkgver = 1.2.3
+ pkgver = 1.3.0
pkgrel = 1
url = http://gitea.io
install = gitea.install
@@ -25,12 +25,12 @@ pkgbase = gitea
conflicts = gitea-git
conflicts = gitea-git-dev
backup = etc/gitea/app.ini
- source = https://github.com/go-gitea/gitea/archive/v1.2.3.tar.gz
+ source = https://github.com/go-gitea/gitea/archive/v1.3.0.tar.gz
source = gitea.service
source = app.ini
- sha512sums = b519bb2fae20da75444a9cb971ab1db0aed04261c6522464feb2e0bad28bc5b8fff3ce8a85f8d26e9cfe79b41c29e540b3ff0aa0c3e99ce90e9e9a1ec26a165e
+ sha512sums = 51cfcb53a039ce8c7995748bd54ea34b88b404de35ef6c9c5742b220fee814fe81670634aa272bbd0002431e70e757b0e460d159e41b7378c93cd5aa820d45f4
sha512sums = 692ea79b3195f3222f69b485f8a7905223fa457dc5cb2b480edbac6f480ac4f74075accb04ae0c17b90e98e41f53224e661a85762310d7263921e763cb3fc257
- sha512sums = 03f2947aa80c1f9a9390b1d9fcce8bd7c930b6ae1afb9ee971666e7259992fe1d4e71584a1268abb2283add8d746aca1749e0b6e7355a7404edeb65d62efea63
+ sha512sums = 47dbc47c7f54c9793749542fd8de1a2b56db8349019b67313d956450a36413abf9457fa1a9082c088c97aca4afa4b121077967247dd1547f142c9646b9479783
pkgname = gitea
diff --git a/PKGBUILD b/PKGBUILD
index 025b1b19f740..8fa195ff1118 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Frederik Schwan <frederik dot schwan at linux dot com>
pkgname=gitea
-pkgver=1.2.3
+pkgver=1.3.0
pkgrel=1
pkgdesc='Git with a cup of tea, forked from Gogs. Is a Self Hosted Git Service in the Go Programming Language.'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -21,9 +21,9 @@ install=gitea.install
source=(https://github.com/go-gitea/gitea/archive/v${pkgver}.tar.gz
gitea.service
app.ini)
-sha512sums=('b519bb2fae20da75444a9cb971ab1db0aed04261c6522464feb2e0bad28bc5b8fff3ce8a85f8d26e9cfe79b41c29e540b3ff0aa0c3e99ce90e9e9a1ec26a165e'
+sha512sums=('51cfcb53a039ce8c7995748bd54ea34b88b404de35ef6c9c5742b220fee814fe81670634aa272bbd0002431e70e757b0e460d159e41b7378c93cd5aa820d45f4'
'692ea79b3195f3222f69b485f8a7905223fa457dc5cb2b480edbac6f480ac4f74075accb04ae0c17b90e98e41f53224e661a85762310d7263921e763cb3fc257'
- '03f2947aa80c1f9a9390b1d9fcce8bd7c930b6ae1afb9ee971666e7259992fe1d4e71584a1268abb2283add8d746aca1749e0b6e7355a7404edeb65d62efea63')
+ '47dbc47c7f54c9793749542fd8de1a2b56db8349019b67313d956450a36413abf9457fa1a9082c088c97aca4afa4b121077967247dd1547f142c9646b9479783')
prepare() {
mkdir -p "${srcdir}/src/code.gitea.io"
diff --git a/app.ini b/app.ini
index bccd8e60e30a..d081eedb0d5e 100644
--- a/app.ini
+++ b/app.ini
@@ -23,6 +23,8 @@ PULL_REQUEST_QUEUE_LENGTH = 1000
PREFERRED_LICENSES = Apache License 2.0,MIT License
; Disable ability to interact with repositories by HTTP protocol
DISABLE_HTTP_GIT = false
+; Force ssh:// clone url instead of scp-style uri when default SSH port is used
+USE_COMPAT_SSH_URI = false
[repository.editor]
; List of file extensions that should have line wraps in the CodeMirror editor
@@ -111,6 +113,8 @@ LOCAL_ROOT_URL = %(PROTOCOL)s://%(HTTP_ADDR)s:%(HTTP_PORT)s/
DISABLE_SSH = false
; Whether use builtin SSH server or not.
START_SSH_SERVER = false
+; Username to use for builtin SSH server. If blank, then it is the value of RUN_USER.
+BUILTIN_SSH_SERVER_USER =
; Domain name to be exposed in clone URL
SSH_DOMAIN = %(DOMAIN)s
; Network interface builtin SSH server listens on
@@ -121,6 +125,15 @@ SSH_PORT = 22
SSH_LISTEN_PORT = %(SSH_PORT)s
; Root path of SSH directory, default is '~/.ssh', but you have to use '/home/git/.ssh'.
SSH_ROOT_PATH =
+; For built-in SSH server only, choose the ciphers to support for SSH connections,
+; for system SSH this setting has no effect
+SSH_SERVER_CIPHERS = aes128-ctr, aes192-ctr, aes256-ctr, aes128-gcm@openssh.com, arcfour256, arcfour128
+; For built-in SSH server only, choose the key exchange algorithms to support for SSH connections,
+; for system SSH this setting has no effect
+SSH_SERVER_KEY_EXCHANGES = diffie-hellman-group1-sha1, diffie-hellman-group14-sha1, ecdh-sha2-nistp256, ecdh-sha2-nistp384, ecdh-sha2-nistp521, curve25519-sha256@libssh.org
+; For built-in SSH server only, choose the MACs to support for SSH connections,
+; for system SSH this setting has no effect
+SSH_SERVER_MACS = hmac-sha2-256-etm@openssh.com, hmac-sha2-256, hmac-sha1, hmac-sha1-96
; Directory to create temporary files when test public key using ssh-keygen,
; default is system temporary directory.
SSH_KEY_TEST_PATH =
@@ -180,10 +193,16 @@ SSL_MODE = disable
PATH = data/gitea.db
; For "sqlite3" only. Query timeout
SQLITE_TIMEOUT = 500
+; For iterate buffer, default is 50
+ITERATE_BUFFER_SIZE = 50
[indexer]
ISSUE_INDEXER_PATH = /var/lib/gitea/indexer/issues.bleve
+; repo indexer by default disabled, since it uses a lot of disk space
+REPO_INDEXER_ENABLED = false
+REPO_INDEXER_PATH = /var/lib/gitea/indexer/repos.bleve
UPDATE_BUFFER_LEN = 20
+MAX_FILE_SIZE = 1048576
[admin]
; Disable regular (non-admin) users to create organizations
@@ -204,6 +223,8 @@ REVERSE_PROXY_AUTHENTICATION_USER = X-WEBAUTH-USER
MIN_PASSWORD_LENGTH = 6
; True when users are allowed to import local server paths
IMPORT_LOCAL_PATHS = false
+; Prevent all users (including admin) from creating custom git hooks
+DISABLE_GIT_HOOKS = false
[openid]
;
@@ -234,7 +255,7 @@ ENABLE_OPENID_SIGNIN = true
; Example value: trusted.domain.org trusted.domain.net
WHITELISTED_URIS =
; Forbidden URI patterns (POSIX regexp).
-; Space sepaated.
+; Space separated.
; Only used if WHITELISTED_URIS is blank.
; Example value: loadaverage.org/badguy stackexchange.com/.*spammer
BLACKLISTED_URIS =
@@ -263,6 +284,12 @@ DEFAULT_KEEP_EMAIL_PRIVATE = false
; Default value for AllowCreateOrganization
; New user will have rights set to create organizations depending on this setting
DEFAULT_ALLOW_CREATE_ORGANIZATION = true
+; Default value for EnableTimetracking
+; Repositories will use timetracking by default depending on this setting
+DEFAULT_ENABLE_TIMETRACKING = true
+; Default value for AllowOnlyContributorsToTrackTime
+; Only users with write permissions could track time if this is true
+DEFAULT_ALLOW_ONLY_CONTRIBUTORS_TO_TRACK_TIME = true
; Default value for the domain part of the user's email address in the git log
; if he has set KeepEmailPrivate true. The user's email replaced with a
; concatenation of the user name in lower case, "@" and NO_REPLY_ADDRESS.
@@ -308,8 +335,10 @@ PASSWD =
SEND_AS_PLAIN_TEXT = false
; Enable sendmail (override SMTP)
USE_SENDMAIL = false
-; Specifiy an alternative sendmail binary
+; Specify an alternative sendmail binary
SENDMAIL_PATH = sendmail
+; Specify any extra sendmail arguments
+SENDMAIL_ARGS =
[cache]
; Either "memory", "redis", or "memcache", default is "memory"
@@ -320,6 +349,9 @@ INTERVAL = 60
; redis: network=tcp,addr=:6379,password=macaron,db=0,pool_size=100,idle_timeout=180
; memcache: `127.0.0.1:11211`
HOST =
+; Time to keep items in cache if not used, default is 16 hours.
+; Setting it to 0 disables caching
+ITEM_TTL = 16h
[session]
; Either "memory", "file", or "redis", default is "memory"
@@ -350,7 +382,7 @@ GRAVATAR_SOURCE = gravatar
DISABLE_GRAVATAR = false
; Federated avatar lookup uses DNS to discover avatar associated
; with emails, see https://www.libravatar.org
-; This value will be forced to be false in offline mode or Gravatar is disbaled.
+; This value will be forced to be false in offline mode or Gravatar is disabled.
ENABLE_FEDERATED_AVATAR = false
[attachment]
@@ -366,7 +398,7 @@ MAX_SIZE = 4
MAX_FILES = 5
[time]
-; Specifies the format for fully outputed dates. Defaults to RFC1123
+; Specifies the format for fully outputted dates. Defaults to RFC1123
; Special supported values are ANSIC, UnixDate, RubyDate, RFC822, RFC822Z, RFC850, RFC1123, RFC1123Z, RFC3339, RFC3339Nano, Kitchen, Stamp, StampMilli, StampMicro and StampNano
; For more information about the format see http://golang.org/pkg/time/#pkg-constants
FORMAT =
@@ -464,7 +496,7 @@ OLDER_THAN = 24h
; Synchronize external user data (only LDAP user synchronization is supported)
[cron.sync_external_users]
-; Syncronize external user data when starting server (default false)
+; Synchronize external user data when starting server (default false)
RUN_AT_START = false
; Interval as a duration between each synchronization (default every 24h)
SCHEDULE = @every 24h
@@ -505,7 +537,7 @@ MAX_RESPONSE_ITEMS = 50
[i18n]
LANGS = en-US,zh-CN,zh-HK,zh-TW,de-DE,fr-FR,nl-NL,lv-LV,ru-RU,ja-JP,es-ES,pt-BR,pl-PL,bg-BG,it-IT,fi-FI,tr-TR,cs-CZ,sr-SP,sv-SE,ko-KR
-NAMES = English,简体中文,繁體中文(香港),繁體中文(台灣),Deutsch,Français,Nederlands,Latviešu,Русский,日本語,Español,Português do Brasil,Polski,български,Italiano,Suomalainen,Türkçe,čeština,Српски,Svenska,한국어
+NAMES = English,简体中文,繁體中文(香港),繁體中文(台灣),Deutsch,Français,Nederlands,Latviešu,Русский,日本語,Español,Português do Brasil,polski,български,Italiano,Suomalainen,Türkçe,čeština,Српски,Svenska,한국어
; Used for datetimepicker
[i18n.datelang]
@@ -541,3 +573,12 @@ SHOW_FOOTER_BRANDING = false
SHOW_FOOTER_VERSION = true
; Show time of template execution in the footer
SHOW_FOOTER_TEMPLATE_LOAD_TIME = true
+
+[markup.asciidoc]
+ENABLED = false
+; List of file extensions that should be rendered by an external command
+FILE_EXTENSIONS = .adoc,.asciidoc
+; External command to render all matching extensions
+RENDER_COMMAND = "asciidoc --out-file=- -"
+; Input is not a standard input but a file
+IS_INPUT_FILE = false