summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Whited2019-02-01 08:05:01 -0600
committerSam Whited2019-02-01 08:05:01 -0600
commit0a041b78df79d8a2e2629f00bf76958c2213d4f7 (patch)
treed2357db215bb9a7cb7a66506496c38cae0db4700
parent8a2068d730bceef95dfde1c90ad04c2b4e6e966e (diff)
downloadaur-0a041b78df79d8a2e2629f00bf76958c2213d4f7.tar.gz
Bump to pull in security fix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1964888b5b3e..bf344fb435d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gitea-git
pkgdesc = Painless self-hosted Git service. Community managed fork of Gogs.
- pkgver = v1.7.0_dev_70_g2d9456137e50
+ pkgver = v1.7.0_dev_131_gf9d4bd53e6ac
pkgrel = 1
url = https://gitea.io/
install = gitea.install
@@ -11,7 +11,7 @@ pkgbase = gitea-git
arch = armv7h
arch = aarch64
license = MIT
- makedepends = go
+ makedepends = go>1.11
makedepends = go-bindata
depends = git
optdepends = mariadb: MariaDB support
diff --git a/PKGBUILD b/PKGBUILD
index a2291a614eb4..96c9e06fa457 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,15 @@
_pkgname='gitea'
pkgname=gitea-git
-pkgver=v1.7.0_dev_70_g2d9456137e50
+pkgver=v1.7.0_dev_131_gf9d4bd53e6ac
pkgrel=1
pkgdesc='Painless self-hosted Git service. Community managed fork of Gogs.'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url='https://gitea.io/'
license=('MIT')
depends=('git')
-makedepends=('go' 'go-bindata')
+makedepends=('go>1.11'
+ 'go-bindata')
optdepends=('mariadb: MariaDB support'
'memcached: MemCached support'
'openssh: GIT over SSH support'
@@ -26,7 +27,7 @@ optdepends=('mariadb: MariaDB support'
backup=('etc/gitea/app.ini')
conflicts=('gitea')
provides=('gitea')
-source=("git+https://github.com/go-gitea/gitea.git"
+source=(git+https://github.com/go-gitea/gitea.git
gitea.tmpfiles
gitea.service
gitea.sysusers
@@ -59,6 +60,7 @@ prepare() {
# Make sure we rebuild the mod file from Gopkg.toml to pick up any changes.
rm -f go.mod
go mod init || true
+ GOCACHE="${srcdir}/cache" go mod download
}
build() {