summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkageru2020-03-15 12:42:55 +0100
committerkageru2020-03-15 12:42:55 +0100
commit671022ce6de3c0460aa9d208c7143a9d4a532a7b (patch)
treeafdfcda0539076c1c164a939c7ae348c909cd5f2
parent132d5b625b2f7e8627b6218e0484e2ddc1f4b6ab (diff)
downloadaur-671022ce6de3c0460aa9d208c7143a9d4a532a7b.tar.gz
Remove unneeded workaround and fix build
Something was changed in the build process which caused make build to fail when building the bindata target. Explicitly setting the tags for both make generate and build fixes that. Also, someone apparently pushed the tag v1.12.0-dev again months after the branch was created, so the package version is now lower than before, with only 15 commits since the tag as opposed to 37 before.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ccf42426c2de..d0273fd51460 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gitea-git
pkgdesc = Painless self-hosted Git service. Community managed fork of Gogs.
- pkgver = v1.12.0_dev_37_gf69f5a9f1
+ pkgver = v1.12.0_dev_15_g28b934b3a
pkgrel = 1
url = https://gitea.io/
install = gitea.install
diff --git a/PKGBUILD b/PKGBUILD
index 17ec092e95d2..990e959a2510 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pkgname='gitea'
pkgname=gitea-git
-pkgver=v1.12.0_dev_37_gf69f5a9f1
+pkgver=v1.12.0_dev_15_g28b934b3a
pkgrel=1
pkgdesc='Painless self-hosted Git service. Community managed fork of Gogs.'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -52,8 +52,6 @@ prepare() {
# Change default repos path for ArchLinux and some additional settings
patch -Np1 -i ../gitea-arch-defaults.patch
- # Workaround for https://github.com/golang/go/issues/33326
- export GOPATH="${srcdir}/gopath"
# Make sure we rebuild the mod file from Gopkg.toml to pick up any changes.
rm -f go.mod
go mod init || true
@@ -64,9 +62,10 @@ build() {
# Be nice to people with read-only ~
export GOCACHE="${srcdir}/cache"
cd ${srcdir}/${_pkgname}
- make generate
LDFLAGS="-linkmode external -extldflags \"${LDFLAGS}\" -X \"code.gitea.io/gitea/modules/setting.AppWorkPath=/var/lib/gitea/\""
- make EXTRA_GOFLAGS="-trimpath" TAGS="bindata sqlite pam" build
+ export TAGS="bindata sqlite pam"
+ make generate
+ make EXTRA_GOFLAGS="-trimpath" build
}
package() {