summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Dubois2019-10-16 06:58:11 +0200
committerErik Dubois2019-10-16 06:58:11 +0200
commit05ba0598cf8a190709d7ae91f441cbacf4bc283f (patch)
tree67a2411e748c90b30eb00f16947c70d90e989af6
parent66bf05e2a087ce3e4ede2c7d841eb89fd6d0857a (diff)
downloadaur-05ba0598cf8a190709d7ae91f441cbacf4bc283f.tar.gz
dependencies added + link to usr/bin
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 24 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff006cf60cfb..b7b23892302c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,20 @@
pkgbase = gitfiend
pkgdesc = A Git client designed for humans
pkgver = 0.19.5
- pkgrel = 1
+ pkgrel = 2
url = https://gitfiend.com
arch = x86_64
- license = custom
+ license = ISC
+ depends = libnotify
+ depends = nss
+ depends = libxss
+ depends = libxtst
+ depends = xdg-utils
+ depends = at-spi2-atk
+ depends = libappindicator-gtk3
+ depends = libsecret
options = !strip
- source = GitFiend_0.19.5_amd64.deb::https://gitfiend.com/resources/GitFiend_0.19.5_amd64.deb
+ source = https://gitfiend.com/resources/GitFiend_0.19.5_amd64.deb
md5sums = b742138f63bb3f0615c9229dcb0fe4bf
pkgname = gitfiend
diff --git a/.gitignore b/.gitignore
index 04eebdd9da58..69361b78dae2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,3 @@
-git.sh \ No newline at end of file
+git.sh
+pkg
+src \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 81b1786d001d..4b8d471cc5fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,18 @@
pkgname=gitfiend
_pkgname=GitFiend
pkgver=0.19.5
-pkgrel=1
+pkgrel=2
pkgdesc='A Git client designed for humans'
arch=('x86_64')
-license=('custom')
-url='https://gitfiend.com'
+license=('ISC')
+depends=('libnotify' 'nss' 'libxss' 'libxtst' 'xdg-utils' 'at-spi2-atk'
+ 'libappindicator-gtk3' 'libsecret')
+url="https://gitfiend.com"
options=('!strip')
-source=("${_pkgname}_${pkgver}_amd64.deb::https://gitfiend.com/resources/${_pkgname}_${pkgver}_amd64.deb")
+source=("https://gitfiend.com/resources/${_pkgname}_${pkgver}_amd64.deb")
md5sums=('b742138f63bb3f0615c9229dcb0fe4bf')
package() {
- cd "${srcdir}"
- tar -xvf data.tar.xz -C "${pkgdir}"
-} \ No newline at end of file
+ tar -xvf data.tar.xz -C ${pkgdir}
+ install -dm755 "$pkgdir/usr/bin"
+ ln -sf "/opt/GitFiend/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}