summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2018-11-08 16:51:23 +0100
committerChristian Hesse2018-11-08 16:51:23 +0100
commit5e15dd10f8f439db31d2addb554e8ae3d52dc176 (patch)
tree5b8f2847e17632ccdbe769705b61db8a7ed0a3f4
parentbed030af46af6422054ee309da2a75b34c71d7cd (diff)
downloadaur-5e15dd10f8f439db31d2addb554e8ae3d52dc176.tar.gz
commit gitg-git 3.30.1.r30.gf7b4e604-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD39
2 files changed, 27 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 605aa06072ff..e7d67b841ebe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = gitg-git
pkgdesc = A GIT repository viewer based on GTK+ - git checkout
- pkgver = 3.17.1.r115.g84eee97
+ pkgver = 3.30.1.r30.gf7b4e604
pkgrel = 1
- url = https://git.gnome.org/browse/gitg/
+ url = https://gitlab.gnome.org/GNOME/gitg/
install = gitg-git.install
arch = i686
arch = x86_64
license = GPL
+ makedepends = meson
makedepends = intltool
makedepends = vala
makedepends = gobject-introspection
@@ -21,8 +22,8 @@ pkgbase = gitg-git
depends = gtkspell3
provides = gitg
conflicts = gitg
- source = git://git.gnome.org/gitg
- source = git://git.gnome.org/libgd
+ source = git+https://gitlab.gnome.org/GNOME/gitg.git
+ source = git+https://gitlab.gnome.org/GNOME/libgd.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 84ae63defc48..6df7593a119c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,43 +2,48 @@
# Contributor: Matt Arsenault <arsenm2@rpi.edu>
pkgname=gitg-git
-pkgver=3.17.1.r115.g84eee97
+pkgver=3.30.1.r30.gf7b4e604
pkgrel=1
pkgdesc='A GIT repository viewer based on GTK+ - git checkout'
arch=('i686' 'x86_64')
-url='https://git.gnome.org/browse/gitg/'
+url='https://gitlab.gnome.org/GNOME/gitg/'
license=('GPL')
depends=('gtksourceview3' 'git' 'desktop-file-utils' 'libgit2-glib' 'libgee' 'webkit2gtk' 'libpeas' 'gtkspell3')
-makedepends=('intltool' 'vala' 'gobject-introspection' 'gnome-common')
+makedepends=('meson' 'intltool' 'vala' 'gobject-introspection' 'gnome-common')
provides=('gitg')
conflicts=('gitg')
install=gitg-git.install
-source=('git://git.gnome.org/gitg'
- 'git://git.gnome.org/libgd')
+source=('git+https://gitlab.gnome.org/GNOME/gitg.git'
+ 'git+https://gitlab.gnome.org/GNOME/libgd.git')
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP')
pkgver() {
cd gitg/
if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ printf '%s.r%s.g%s' \
+ "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
+ "$(git rev-list --count ${GITTAG}..)" \
+ "$(git rev-parse --short HEAD)"
else
- echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ printf '0.r%s.g%s' \
+ "$(git rev-list --count master)" \
+ "$(git rev-parse --short HEAD)"
fi
}
build() {
- cd gitg/
-
- ./autogen.sh --prefix=/usr --disable-debug
-
- make
+ arch-meson gitg build
+ ninja -C build
}
-package() {
- cd gitg/
-
- make DESTDIR="${pkgdir}" install
+check() {
+ meson test -C build
}
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+ python -m compileall -d /usr/lib "${pkgdir}/usr/lib"
+ python -O -m compileall -d /usr/lib "${pkgdir}/usr/lib"
+} \ No newline at end of file