summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Kohlmeyer2018-03-22 15:59:20 +0100
committerSimon Kohlmeyer2018-03-22 16:12:38 +0100
commit0faa5ac56603d9b4bbc5bff81648ddf5d84ae1ff (patch)
treed715761fda8fa0cb5b941e3e932d60a7b9cd6856
downloadaur-0faa5ac56603d9b4bbc5bff81648ddf5d84ae1ff.tar.gz
v1.3.7
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD44
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a4076b77d35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Thu Mar 22 15:09:41 UTC 2018
+pkgbase = githud
+ pkgdesc = heads up display for the command line that will show git information
+ pkgver = 1.3.7
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/gitHUD
+ arch = x86_64
+ license = BSD3
+ makedepends = ghc
+ depends = ghc
+ depends = ghc-libs
+ depends = haskell-mtl
+ depends = haskell-parsec
+ depends = haskell-text
+ depends = haskell-unix
+ depends = haskell-process
+ source = http://hackage.haskell.org/packages/archive/gitHUD/1.3.7/gitHUD-1.3.7.tar.gz
+ sha256sums = dc38431b13d2dc4625987131c1389ed4ab67154990035c0c66f30d90d1a344af
+
+pkgname = githud
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3f1864bb0ec4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d798ea62506b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: Simon Kohlmeyer <simon.kohlmeyer@gmail.com>
+
+_hkgname=gitHUD
+pkgname=githud
+pkgver=1.3.7
+pkgrel=1
+pkgdesc="heads up display for the command line that will show git information"
+url="http://hackage.haskell.org/package/$_hkgname"
+license=("BSD3")
+arch=('x86_64')
+depends=('ghc' 'ghc-libs' 'haskell-mtl' 'haskell-parsec' 'haskell-text' 'haskell-unix' 'haskell-process')
+makedepends=('ghc')
+source=(http://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz)
+sha256sums=('dc38431b13d2dc4625987131c1389ed4ab67154990035c0c66f30d90d1a344af')
+
+build() {
+ cd "$srcdir/$_hkgname-$pkgver"
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
+ -fcurl -fpkgconfig -f-static -fterminfo -fthreaded -fexecutable \
+ -f-rts -foptimize -f-warn-as-error -f-libiconv
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd $_hkgname-$pkgver
+
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ runhaskell Setup copy --destdir="${pkgdir}"
+
+ # The generated binary is called gitHUD, but it's probably convenient to be able to call it
+ # githud instead
+ ln -s gitHUD "${pkgdir}/usr/bin/githud"
+
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}